]> code.delx.au - refind/blobdiff - refind.spec
Fixed uninitialized-pointer bug that manifested as a crash with
[refind] / refind.spec
index 267e2be495e8c6c2f9790f412b335e60cd718ae2..c3849cdaa4a11ca1b7e1ccc165cf40e902778a68 100644 (file)
@@ -1,6 +1,6 @@
 Summary: EFI boot manager software
 Name: refind
-Version: 0.9.2.4
+Version: 0.10.3
 Release: 1%{?dist}
 Summary: EFI boot manager software
 License: GPLv3
@@ -37,7 +37,7 @@ A graphical boot manager for EFI- and UEFI-based computers, such as all
 Intel-based Macs and recent (most 2011 and later) PCs. rEFInd presents a
 boot menu showing all the EFI boot loaders on the EFI-accessible
 partitions, and optionally BIOS-bootable partitions on Macs and BIOS boot
-entries on UEFI PCs with CSMs. EFI-compatbile OSes, including Linux,
+entries on UEFI PCs with CSMs. EFI-compatible OSes, including Linux,
 provide boot loaders that rEFInd can detect and launch. rEFInd can launch
 Linux EFI boot loaders such as ELILO, GRUB Legacy, GRUB 2, and 3.3.0 and
 later kernels with EFI stub support. EFI filesystem drivers for ext2/3/4fs,
@@ -90,9 +90,17 @@ install -Dp -m0755 refind-install $RPM_BUILD_ROOT/usr/share/refind-%{version}/
 
 # Copy documentation to /usr/share/doc/refind-%{version}
 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/refind-%{version}
-cp -a docs/* $RPM_BUILD_ROOT/usr/share/doc/refind-%{version}/
+cp -a docs/Styles $RPM_BUILD_ROOT/usr/share/doc/refind-%{version}/
+cp -a docs/refind $RPM_BUILD_ROOT/usr/share/doc/refind-%{version}/
 install -Dp -m0644 NEWS.txt COPYING.txt LICENSE.txt README.txt CREDITS.txt $RPM_BUILD_ROOT/usr/share/doc/refind-%{version}
 
+# Copy man pages to /usr/share/man/man8
+mkdir -p $RPM_BUILD_ROOT/usr/share/man/man8
+install -Dp -m0644 docs/man/mvrefind.8 $RPM_BUILD_ROOT/usr/share/man/man8
+install -Dp -m0644 docs/man/mkrlconf.8 $RPM_BUILD_ROOT/usr/share/man/man8
+install -Dp -m0644 docs/man/refind-install.8 $RPM_BUILD_ROOT/usr/share/man/man8
+install -Dp -m0644 docs/man/refind-mkdefault.8 $RPM_BUILD_ROOT/usr/share/man/man8
+
 # Copy keys to /etc/refind.d/keys
 mkdir -p $RPM_BUILD_ROOT/etc/refind.d/keys
 install -Dp -m0644 keys/* $RPM_BUILD_ROOT/etc/refind.d/keys
@@ -101,6 +109,8 @@ install -Dp -m0644 keys/* $RPM_BUILD_ROOT/etc/refind.d/keys
 mkdir -p $RPM_BUILD_ROOT/usr/sbin
 install -Dp -m0755 mkrlconf $RPM_BUILD_ROOT/usr/sbin/
 install -Dp -m0755 mvrefind $RPM_BUILD_ROOT/usr/sbin/
+install -Dp -m0755 refind-mkdefault $RPM_BUILD_ROOT/usr/sbin/
+ln -sr $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind-install $RPM_BUILD_ROOT/usr/sbin
 
 # Copy banners and fonts to /usr/share/refind-%{version}
 cp -a banners $RPM_BUILD_ROOT/usr/share/refind-%{version}/
@@ -112,8 +122,11 @@ cp -a fonts $RPM_BUILD_ROOT/usr/share/refind-%{version}/
 %files
 %defattr(-,root,root -)
 %doc /usr/share/doc/refind-%{version}
+%doc /usr/share/man/man8
 /usr/sbin/mkrlconf
 /usr/sbin/mvrefind
+/usr/sbin/refind-install
+/usr/sbin/refind-mkdefault
 /usr/share/refind-%{version}
 /etc/refind.d/
 
@@ -156,11 +169,7 @@ if [[ $IsSecureBoot == "1" && -n $ShimFile ]] ; then
       ./refind-install --shim $ShimFile --yes
    fi
 else
-   if [[ -n $SBSign && -n $OpenSSL ]] ; then
-      ./refind-install --localkeys --yes
-   else
-      ./refind-install --yes
-   fi
+   ./refind-install --yes
 fi
 
 # CAUTION: Don't create a %preun or a %postun script that deletes the files
@@ -168,6 +177,14 @@ fi
 # thus wiping out the just-updated files.
 
 %changelog
+* Sun Apr 24 2016 R Smith <rodsmith@rodsbooks.com> - 0.10.3
+- Updated spec file for 0.10.3
+* Tue Jan 26 2016 R Smith <rodsmith@rodsbooks.com> - 0.10.2
+- Updated spec file for 0.10.2
+* Sat Dec 12 2015 R Smith <rodsmith@rodsbooks.com> - 0.10.1
+- Updated spec file for 0.10.1
+* Sun Nov 8 2015 R Smith <rodsmith@rodsbooks.com> - 0.10.0
+- Updated spec file for 0.10.0
 * Sat Sep 19 2015 R Smith <rodsmith@rodsbooks.com> - 0.9.2
 - Updated spec file for 0.9.2
 * Sun Sep 13 2015 R Smith <rodsmith@rodsbooks.com> - 0.9.1
@@ -178,7 +195,7 @@ fi
 - Updated spec file for 0.8.7
 * Sun Feb 8 2015 R Smith <rodsmith@rodsbooks.com> - 0.8.6
 - Updated spec file for 0.8.6
-* Sun Feb 2 2015 R Smith <rodsmith@rodsbooks.com> - 0.8.5
+* Sun Feb 1 2015 R Smith <rodsmith@rodsbooks.com> - 0.8.5
 - Updated spec file for 0.8.5
 * Mon Dec 8 2014 R Smith <rodsmith@rodsbooks.com> - 0.8.4
 - Updated spec file for 0.8.4