]> code.delx.au - refind/blobdiff - refind.spec
Version 0.8.1 release.
[refind] / refind.spec
index 55f2103236aa5e0b54023927e287b36bc9a88d3f..3ab1ee5d9a0056c26b303af38dd1b6da5f8c84ad 100644 (file)
@@ -1,6 +1,6 @@
 Summary: EFI boot manager software
 Name: refind
-Version: 0.7.4
+Version: 0.8.1
 Release: 1%{?dist}
 Summary: EFI boot manager software
 License: GPLv3
@@ -126,7 +126,9 @@ fi
 cd /usr/share/refind-%{version}
 
 declare VarFile=`ls -d /sys/firmware/efi/vars/SecureBoot* 2> /dev/null`
-declare ShimFile=`find /boot -name shim\.efi 2> /dev/null | head -n 1`
+# Note: Two find operations for ShimFile favors shim over PreLoader -- if both are
+# present, the script uses shim rather than PreLoader.
+declare ShimFile=`find /boot -name shim\.efi -o -name shimx64\.efi -o -name PreLoader\.efi 2> /dev/null | head -n 1`
 if [[ ! -n $ShimFile ]] ; then
    declare ShimFile=`find /boot -name PreLoader\.efi 2> /dev/null | head -n 1`
 fi
@@ -157,5 +159,13 @@ fi
 # wiping out the just-updated files.
 
 %changelog
-* Sun Aug 25 2013 R Smith <rodsmith@rodsbooks.com> - 0.7.4
-- Created spec file for 0.7.4 release
+* Thu May 15 2014 R Smith <rodsmith@rodsbooks.com> - 0.8.1
+- Updated spec file for 0.8.0
+* Sun May 4 2014 R Smith <rodsmith@rodsbooks.com> - 0.8.0
+- Updated spec file for 0.8.0
+* Sun Apr 20 2014 R Smith <rodsmith@rodsbooks.com> - 0.7.9
+- Updated spec file for 0.7.9
+* Sun Mar 9 2014 R Smith <rodsmith@rodsbooks.com> - 0.7.8
+- Updated spec file for 0.7.8
+* Fri Jan 3 2014 R Smith <rodsmith@rodsbooks.com> - 0.7.7
+- Created spec file for 0.7.7 release