]> code.delx.au - refind/blobdiff - refind.spec
Reverted rEFIt commit r472, since it's caused some existing BMP
[refind] / refind.spec
index 87e5e399b1a41a4a258be8e599e9e0e1db8c3c47..f44a67aaec870932fe0782d5aa493c4ca388c0aa 100644 (file)
@@ -1,6 +1,6 @@
 Summary: EFI boot manager software
 Name: refind
-Version: 0.7.0
+Version: 0.8.5
 Release: 1%{?dist}
 Summary: EFI boot manager software
 License: GPLv3
@@ -49,7 +49,7 @@ when paired with Linux kernels that provide EFI stub support.
 %setup -q
 
 %build
-if [[ -d /usr/local/UDK2010 ]] ; then
+if [[ -d /usr/local/UDK2014 ]] ; then
    make
    make fs
 else
@@ -126,7 +126,9 @@ fi
 cd /usr/share/refind-%{version}
 
 declare VarFile=`ls -d /sys/firmware/efi/vars/SecureBoot* 2> /dev/null`
-declare ShimFile=`find /boot -name shim\.efi 2> /dev/null | head -n 1`
+# Note: Two find operations for ShimFile favors shim over PreLoader -- if both are
+# present, the script uses shim rather than PreLoader.
+declare ShimFile=`find /boot -name shim\.efi -o -name shimx64\.efi -o -name PreLoader\.efi 2> /dev/null | head -n 1`
 if [[ ! -n $ShimFile ]] ; then
    declare ShimFile=`find /boot -name PreLoader\.efi 2> /dev/null | head -n 1`
 fi
@@ -157,5 +159,21 @@ fi
 # wiping out the just-updated files.
 
 %changelog
-* Thu Jun 27 2013 R Smith <rodsmith@rodsbooks.com> - 0.7.0
-- Created spec file for 0.7.0 release
+* Sun Feb 2 2015 R Smith <rodsmith@rodsbooks.com> - 0.8.5
+- Updated spec file for 0.8.5
+* Mon Dec 8 2014 R Smith <rodsmith@rodsbooks.com> - 0.8.4
+- Updated spec file for 0.8.4
+* Sun Jul 6 2014 R Smith <rodsmith@rodsbooks.com> - 0.8.3
+- Updated spec file for 0.8.3
+* Sun Jun 8 2014 R Smith <rodsmith@rodsbooks.com> - 0.8.2
+- Updated spec file for 0.8.2
+* Thu May 15 2014 R Smith <rodsmith@rodsbooks.com> - 0.8.1
+- Updated spec file for 0.8.1
+* Sun May 4 2014 R Smith <rodsmith@rodsbooks.com> - 0.8.0
+- Updated spec file for 0.8.0
+* Sun Apr 20 2014 R Smith <rodsmith@rodsbooks.com> - 0.7.9
+- Updated spec file for 0.7.9
+* Sun Mar 9 2014 R Smith <rodsmith@rodsbooks.com> - 0.7.8
+- Updated spec file for 0.7.8
+* Fri Jan 3 2014 R Smith <rodsmith@rodsbooks.com> - 0.7.7
+- Created spec file for 0.7.7 release