]> code.delx.au - offlineimap/blob - offlineimap/head/debian/changelog
/offlineimap/head: changeset 142
[offlineimap] / offlineimap / head / debian / changelog
1 offlineimap (3.0.3) unstable; urgency=low
2
3 * Placeholder.
4
5 -- John Goerzen <jgoerzen@complete.org> Thu, 18 Jul 2002 17:46:13 -0500
6
7 offlineimap (3.0.2) unstable; urgency=low
8
9 * Fixed mailbox name recorder to use localfolder.getvisiblename() rather
10 than remotefolder.getvisiblename()
11 * Fixed remotepassfile option. Closes: #153119. Used 1-line patch from
12 Tommi Virtanen.
13 * Now handles cases of not being able to get UID for an uploaded message
14 more gracefully. This could occur if the server doesn't support
15 SEARCH, can't find the message ID, or finds multiple message IDs.
16 Closes: #153241.
17 * Now source is in Subversion. Make version.py log the Subversion
18 revision number.
19
20 -- John Goerzen <jgoerzen@complete.org> Wed, 15 Jul 2002 06:43:36 -0500
21
22 offlineimap (3.0.1) unstable; urgency=low
23
24 * Detabified the source.
25 * Added UI list to the manpage.
26 * Added -o (run only once) option with patch sent in by Martijn Pieters.
27 * Optimized folder/IMAP.py addmessagesflags() with new listjoin() in
28 imaputil. Now, send the server 1:5,7 instead of 1,2,3,4,5,7.
29 * Made folder/Maildir.py/deletemessage() more tolerant if a message
30 asked to be deleted already has been.
31 * In Base.py/copymessageto(), no longer bother calling getmessage()
32 unless a folder's storemessages() returns true. This will also help
33 with syncing to LocalStatus if the user deleted messages in the
34 Maildir since the cachemessagelist() was called.
35
36 -- John Goerzen <jgoerzen@complete.org> Fri, 12 Jul 2002 07:28:24 -0500
37
38 offlineimap (3.0.0) unstable; urgency=low
39
40 * Introduced a new graphical user interface written with Tkinter.
41 It features a nice view of multi-threaded displays.
42 * The TTY user interface now also displays thread names.
43 * Program-wide, new threads are given descriptive names to aid in
44 debugging and status messages.
45 * Added new module offlineimap/ui/detect.py that is used to detect
46 which user interface to select for a given session. Its operation
47 is governed by the ui config option and the -u command-line option.
48 * Made IMAP folder addmessagesflags() resiliant to a server refusing
49 to return a full set of new message flags. Closes: #152587.
50 * Completely rewrote documentation. OfflineIMAP now has an
51 exhaustive manpage, which is really a manual. It is also shipped
52 in plain text, HTML, PDF, and PostScript formats.
53 * New command-line options:
54 -1 to force no multi-threaded operation
55 -u to force a particular UI
56 -a to specify which accounts to sync
57 -h to print help
58 -c to specify an alternate config file
59 * Added a workaround for UW IMAP problem wherein the server loses
60 uidvalidity whenever a folder is emptied. Now, the program
61 will not consider it a problem if uidvalidity is lost when a folder
62 and the local status cache are both completely empty, since we do
63 not really need to preserve uidvalidity in that case anyway.
64 Closes: #152079.
65
66 -- John Goerzen <jgoerzen@complete.org> Thu, 11 Jul 2002 22:35:42 -0500
67
68 offlineimap (2.0.8) unstable; urgency=low
69
70 * Modified the IMAP folder to use SELECT rather than STATUS more often.
71 Makes the code more robust; handles better with read-only folders;
72 and runs faster, especially for non-threaded useres, where it
73 may eliminate up to 2-3 commands per folder.
74 * Made sure IMAP folder savemessage() does a select. This was a possible
75 bug.
76 * Modified Maildir folder to unlink messages with T flag in
77 cachemessagelist()
78 * My own box now syncs in 3 seconds.
79 * Optimized acquireconnection() to try to give a thread back the
80 connection that it last used, if possible.
81
82 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 23:29:30 -0500
83
84 offlineimap (2.0.7) unstable; urgency=low
85
86 * Fixed imaplib.py to work better with read-only folders.
87
88 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:24:21 -0500
89
90 offlineimap (2.0.6) unstable; urgency=low
91
92 * Added support for holdconnectionopen and keepalive. This feature
93 allows for an IMAP server connection(s) to be held open until
94 the next sync process, permitting faster restart times.
95 * Another try at read-only folder support. This is nasty because I
96 have no way to test it and imaplib's read-only support is weird.
97 * Closing out old bug; fixed in 1.0.2. Closes: #150803.
98 * Optimized algorithm so that a SELECT is never issued for folders
99 that contain no messages.
100
101 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:05:24 -0500
102
103 offlineimap (2.0.5) unstable; urgency=low
104
105 * Fixed a folderfilter example. Partially fixes #152079.
106 * Added folderincludes capability. Partially fixes #152079.
107 * More fixes for read-only folders.
108
109 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:21:52 -0500
110
111 offlineimap (2.0.4) unstable; urgency=low
112
113 * Made OfflineIMAP at least rudimentarily compatible with read-only
114 folders. It will still fail if they get modified locally, though.
115 * Flags are handled case-insensitively. Closes: #151993.
116
117 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:10:29 -0500
118
119 offlineimap (2.0.3) unstable; urgency=low
120
121 * Added support for specifying references. Closes: #151960.
122 * Added -d command-line option to enable imaplib debugging.
123
124 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 20:39:29 -0500
125
126 offlineimap (2.0.2) unstable; urgency=low
127
128 * Added support for remotepassfile. Closes: #151943.
129 * Added support for preauth tunnels.
130
131 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 14:46:23 -0500
132
133 offlineimap (2.0.1) unstable; urgency=low
134
135 * Fixed a bug with not properly propogating foldersep changes.
136 Now, local folders and status folders properly use the foldersep
137 mechanism. This corrects a problem with Exchange servers.
138 * Wrote a major new thread montiring subsystem, defined a new
139 ExitNotifyThread. Handling of Ctrl-C now occurs within 1 second
140 rather than after the whole program terminates. Exceptions that
141 occur in a thread are now caught by the main thread and marshalled
142 over into the UI side of things for dispatch. The entire program will
143 now abort when one thread dies with an exception.
144
145 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 09:07:06 -0500
146
147 offlineimap (2.0.0) unstable; urgency=low
148
149 * This code is now multithreaded. New config file options control the
150 behavior. This can make synchronizing several times faster.
151 * Fixed the STATUS call to be compatible with Exchange.
152 * Added the ability to exclude folders.
153 * If upgrading from 1.0.x, you will need to add maxsyncaccounts to the
154 general section and maxconnections to each account sections.
155 There is also a new folderfilter option.
156 You can find examples of all of these in the new offlineimap.conf
157 example file packaged with the distribution.
158 * The Debian package now properly installs the example offlineimap.conf
159 file.
160 * There is a new mailing list available. To join, send SUBSCRIBE
161 to offlineimap-request@complete.org. The posting address is
162 offlineimap@complete.org.
163
164 -- John Goerzen <jgoerzen@complete.org> Wed, 3 Jul 2002 19:21:32 -0500
165
166 offlineimap (1.0.4) unstable; urgency=low
167
168 * Deletion of more than one message has been optimized. This could make
169 deleting large numbers of messages far faster -- several orders of
170 magnitude.
171 * Moved more sleep code into ui layer. Fancier sleep actions are now
172 possible. Better handling of Ctrl-C in TTY handler.
173
174 -- John Goerzen <jgoerzen@complete.org> Tue, 2 Jul 2002 19:16:04 -0500
175
176 offlineimap (1.0.3) unstable; urgency=low
177
178 * Fixed a bug when a message was deleted on the IMAP side and modified
179 on the local side.
180
181 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 19:08:21 -0500
182
183 offlineimap (1.0.2) unstable; urgency=low
184
185 * Made sure that LocalStatus does writing atomically. If the program
186 is interrupted during save(), there will always be a complete copy of
187 either the old or the new data.
188
189 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 06:57:28 -0500
190
191 offlineimap (1.0.1) unstable; urgency=low
192
193 * Fixed a bug with writing messages to some IMAP servers. Turns
194 out we need to issue CHECK between APPEND and SEARCH for some.
195 Thanks to Donovan Lange for reporting this bug and helping track it
196 down.
197
198 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 22:03:12 -0500
199
200 offlineimap (1.0.0) unstable; urgency=low
201
202 * Initial Release. Closes: #150571.
203
204 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 18:54:56 -0500
205
206 Local variables:
207 mode: debian-changelog
208 End: