]> code.delx.au - offlineimap/blob - offlineimap/head/debian/changelog
/offlineimap/head: changeset 149
[offlineimap] / offlineimap / head / debian / changelog
1 offlineimap (3.0.3) unstable; urgency=low
2
3 * No longer throws an exception when updating messages with strange
4 Date headers; will just set IMAP Internaldate to the current date.
5 Closes: #153425.
6 * No longer doubles-up reference names for mailboxes. Closes: #153515.
7 * Noted new bug-tracking system in manual and rebuilt manual files.
8
9 -- John Goerzen <jgoerzen@complete.org> Thu, 18 Jul 2002 17:46:13 -0500
10
11 offlineimap (3.0.2) unstable; urgency=low
12
13 * Fixed mailbox name recorder to use localfolder.getvisiblename() rather
14 than remotefolder.getvisiblename()
15 * Fixed remotepassfile option. Closes: #153119. Used 1-line patch from
16 Tommi Virtanen.
17 * Now handles cases of not being able to get UID for an uploaded message
18 more gracefully. This could occur if the server doesn't support
19 SEARCH, can't find the message ID, or finds multiple message IDs.
20 Closes: #153241.
21 * Now source is in Subversion. Make version.py log the Subversion
22 revision number.
23
24 -- John Goerzen <jgoerzen@complete.org> Wed, 15 Jul 2002 06:43:36 -0500
25
26 offlineimap (3.0.1) unstable; urgency=low
27
28 * Detabified the source.
29 * Added UI list to the manpage.
30 * Added -o (run only once) option with patch sent in by Martijn Pieters.
31 * Optimized folder/IMAP.py addmessagesflags() with new listjoin() in
32 imaputil. Now, send the server 1:5,7 instead of 1,2,3,4,5,7.
33 * Made folder/Maildir.py/deletemessage() more tolerant if a message
34 asked to be deleted already has been.
35 * In Base.py/copymessageto(), no longer bother calling getmessage()
36 unless a folder's storemessages() returns true. This will also help
37 with syncing to LocalStatus if the user deleted messages in the
38 Maildir since the cachemessagelist() was called.
39
40 -- John Goerzen <jgoerzen@complete.org> Fri, 12 Jul 2002 07:28:24 -0500
41
42 offlineimap (3.0.0) unstable; urgency=low
43
44 * Introduced a new graphical user interface written with Tkinter.
45 It features a nice view of multi-threaded displays.
46 * The TTY user interface now also displays thread names.
47 * Program-wide, new threads are given descriptive names to aid in
48 debugging and status messages.
49 * Added new module offlineimap/ui/detect.py that is used to detect
50 which user interface to select for a given session. Its operation
51 is governed by the ui config option and the -u command-line option.
52 * Made IMAP folder addmessagesflags() resiliant to a server refusing
53 to return a full set of new message flags. Closes: #152587.
54 * Completely rewrote documentation. OfflineIMAP now has an
55 exhaustive manpage, which is really a manual. It is also shipped
56 in plain text, HTML, PDF, and PostScript formats.
57 * New command-line options:
58 -1 to force no multi-threaded operation
59 -u to force a particular UI
60 -a to specify which accounts to sync
61 -h to print help
62 -c to specify an alternate config file
63 * Added a workaround for UW IMAP problem wherein the server loses
64 uidvalidity whenever a folder is emptied. Now, the program
65 will not consider it a problem if uidvalidity is lost when a folder
66 and the local status cache are both completely empty, since we do
67 not really need to preserve uidvalidity in that case anyway.
68 Closes: #152079.
69
70 -- John Goerzen <jgoerzen@complete.org> Thu, 11 Jul 2002 22:35:42 -0500
71
72 offlineimap (2.0.8) unstable; urgency=low
73
74 * Modified the IMAP folder to use SELECT rather than STATUS more often.
75 Makes the code more robust; handles better with read-only folders;
76 and runs faster, especially for non-threaded useres, where it
77 may eliminate up to 2-3 commands per folder.
78 * Made sure IMAP folder savemessage() does a select. This was a possible
79 bug.
80 * Modified Maildir folder to unlink messages with T flag in
81 cachemessagelist()
82 * My own box now syncs in 3 seconds.
83 * Optimized acquireconnection() to try to give a thread back the
84 connection that it last used, if possible.
85
86 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 23:29:30 -0500
87
88 offlineimap (2.0.7) unstable; urgency=low
89
90 * Fixed imaplib.py to work better with read-only folders.
91
92 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:24:21 -0500
93
94 offlineimap (2.0.6) unstable; urgency=low
95
96 * Added support for holdconnectionopen and keepalive. This feature
97 allows for an IMAP server connection(s) to be held open until
98 the next sync process, permitting faster restart times.
99 * Another try at read-only folder support. This is nasty because I
100 have no way to test it and imaplib's read-only support is weird.
101 * Closing out old bug; fixed in 1.0.2. Closes: #150803.
102 * Optimized algorithm so that a SELECT is never issued for folders
103 that contain no messages.
104
105 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:05:24 -0500
106
107 offlineimap (2.0.5) unstable; urgency=low
108
109 * Fixed a folderfilter example. Partially fixes #152079.
110 * Added folderincludes capability. Partially fixes #152079.
111 * More fixes for read-only folders.
112
113 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:21:52 -0500
114
115 offlineimap (2.0.4) unstable; urgency=low
116
117 * Made OfflineIMAP at least rudimentarily compatible with read-only
118 folders. It will still fail if they get modified locally, though.
119 * Flags are handled case-insensitively. Closes: #151993.
120
121 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:10:29 -0500
122
123 offlineimap (2.0.3) unstable; urgency=low
124
125 * Added support for specifying references. Closes: #151960.
126 * Added -d command-line option to enable imaplib debugging.
127
128 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 20:39:29 -0500
129
130 offlineimap (2.0.2) unstable; urgency=low
131
132 * Added support for remotepassfile. Closes: #151943.
133 * Added support for preauth tunnels.
134
135 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 14:46:23 -0500
136
137 offlineimap (2.0.1) unstable; urgency=low
138
139 * Fixed a bug with not properly propogating foldersep changes.
140 Now, local folders and status folders properly use the foldersep
141 mechanism. This corrects a problem with Exchange servers.
142 * Wrote a major new thread montiring subsystem, defined a new
143 ExitNotifyThread. Handling of Ctrl-C now occurs within 1 second
144 rather than after the whole program terminates. Exceptions that
145 occur in a thread are now caught by the main thread and marshalled
146 over into the UI side of things for dispatch. The entire program will
147 now abort when one thread dies with an exception.
148
149 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 09:07:06 -0500
150
151 offlineimap (2.0.0) unstable; urgency=low
152
153 * This code is now multithreaded. New config file options control the
154 behavior. This can make synchronizing several times faster.
155 * Fixed the STATUS call to be compatible with Exchange.
156 * Added the ability to exclude folders.
157 * If upgrading from 1.0.x, you will need to add maxsyncaccounts to the
158 general section and maxconnections to each account sections.
159 There is also a new folderfilter option.
160 You can find examples of all of these in the new offlineimap.conf
161 example file packaged with the distribution.
162 * The Debian package now properly installs the example offlineimap.conf
163 file.
164 * There is a new mailing list available. To join, send SUBSCRIBE
165 to offlineimap-request@complete.org. The posting address is
166 offlineimap@complete.org.
167
168 -- John Goerzen <jgoerzen@complete.org> Wed, 3 Jul 2002 19:21:32 -0500
169
170 offlineimap (1.0.4) unstable; urgency=low
171
172 * Deletion of more than one message has been optimized. This could make
173 deleting large numbers of messages far faster -- several orders of
174 magnitude.
175 * Moved more sleep code into ui layer. Fancier sleep actions are now
176 possible. Better handling of Ctrl-C in TTY handler.
177
178 -- John Goerzen <jgoerzen@complete.org> Tue, 2 Jul 2002 19:16:04 -0500
179
180 offlineimap (1.0.3) unstable; urgency=low
181
182 * Fixed a bug when a message was deleted on the IMAP side and modified
183 on the local side.
184
185 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 19:08:21 -0500
186
187 offlineimap (1.0.2) unstable; urgency=low
188
189 * Made sure that LocalStatus does writing atomically. If the program
190 is interrupted during save(), there will always be a complete copy of
191 either the old or the new data.
192
193 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 06:57:28 -0500
194
195 offlineimap (1.0.1) unstable; urgency=low
196
197 * Fixed a bug with writing messages to some IMAP servers. Turns
198 out we need to issue CHECK between APPEND and SEARCH for some.
199 Thanks to Donovan Lange for reporting this bug and helping track it
200 down.
201
202 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 22:03:12 -0500
203
204 offlineimap (1.0.0) unstable; urgency=low
205
206 * Initial Release. Closes: #150571.
207
208 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 18:54:56 -0500
209
210 Local variables:
211 mode: debian-changelog
212 End: