]> code.delx.au - offlineimap/blob - offlineimap/head/debian/changelog
/offlineimap/head: changeset 187
[offlineimap] / offlineimap / head / debian / changelog
1 offlineimap (3.2.0) unstable; urgency=low
2
3 * New BLINKENLIGHTS interface! Mesmerising, isn't it?
4 * New ui.Tk.Blinkenlights section in offlineimap.conf.
5 * New USER INTERFACES section in the manual.
6 * TTYUI isusable() now checks to see if stdout and stdin are TTYs.
7 * Added build-dependency on python2.2-dev. Closes: #154167.
8
9 -- John Goerzen <jgoerzen@complete.org> Wed, 24 Jul 2002 17:53:20 -0500
10
11 offlineimap (3.1.1) unstable; urgency=low
12
13 * Modified imaputil.py and folder/Maildir.py to run faster. Eliminated
14 many regular expressions; pre-compiled many others.
15 * Fixed threadutil's exitnotifyloop to always handle threads in the order
16 they exited, rather than sometimes in the inverse order. This way,
17 make sure to handle thread's exception messages before a thread exited.
18 * Replaced imaplib.py's braindead readline() with a more efficient one.
19 * More optimizations to imaputil and folders for faster operation.
20 * These optimizations, all together, have resulted in OfflineIMAP
21 using approximately half the CPU time of previous versions, fixing
22 [complete.org #6], and... Closes: #153503.
23
24 -- John Goerzen <jgoerzen@complete.org> Wed, 24 Jul 2002 06:53:16 -0500
25
26 offlineimap (3.1.0) unstable; urgency=low
27
28 * When uploading messages from a Maildir, now convert \r\n to \n in case
29 the message is stored weirdly. That way, everything is uniform.
30 Fixes [complete.org #11].
31 * Manual: added UW IMAPD example with references from docwhat@gerf.org.
32 * New UI modules: Noninteractive.Basic and Noninteractive.Quiet.
33 Fixes [complete.org #14].
34 * Added per-thread profiling support to aid in debugging.
35
36 -- John Goerzen <jgoerzen@complete.org> Sun, 21 Jul 2002 16:09:42 -0500
37
38 offlineimap (3.0.3) unstable; urgency=low
39
40 * No longer throws an exception when updating messages with strange
41 Date headers; will just set IMAP Internaldate to the current date.
42 Closes: #153425.
43 * No longer doubles-up reference names for mailboxes. Closes: #153515.
44 * Noted new bug-tracking system in manual and rebuilt manual files.
45 * Now stores incoming messages in 'cur' instead of 'new' if they have
46 the S flag. Closes: #152482.
47
48 -- John Goerzen <jgoerzen@complete.org> Sun, 21 Jul 2002 13:46:13 -0500
49
50 offlineimap (3.0.2) unstable; urgency=low
51
52 * Fixed mailbox name recorder to use localfolder.getvisiblename() rather
53 than remotefolder.getvisiblename()
54 * Fixed remotepassfile option. Closes: #153119. Used 1-line patch from
55 Tommi Virtanen.
56 * Now handles cases of not being able to get UID for an uploaded message
57 more gracefully. This could occur if the server doesn't support
58 SEARCH, can't find the message ID, or finds multiple message IDs.
59 Closes: #153241.
60 * Now source is in Subversion. Make version.py log the Subversion
61 revision number.
62
63 -- John Goerzen <jgoerzen@complete.org> Wed, 15 Jul 2002 06:43:36 -0500
64
65 offlineimap (3.0.1) unstable; urgency=low
66
67 * Detabified the source.
68 * Added UI list to the manpage.
69 * Added -o (run only once) option with patch sent in by Martijn Pieters.
70 * Optimized folder/IMAP.py addmessagesflags() with new listjoin() in
71 imaputil. Now, send the server 1:5,7 instead of 1,2,3,4,5,7.
72 * Made folder/Maildir.py/deletemessage() more tolerant if a message
73 asked to be deleted already has been.
74 * In Base.py/copymessageto(), no longer bother calling getmessage()
75 unless a folder's storemessages() returns true. This will also help
76 with syncing to LocalStatus if the user deleted messages in the
77 Maildir since the cachemessagelist() was called.
78
79 -- John Goerzen <jgoerzen@complete.org> Fri, 12 Jul 2002 07:28:24 -0500
80
81 offlineimap (3.0.0) unstable; urgency=low
82
83 * Introduced a new graphical user interface written with Tkinter.
84 It features a nice view of multi-threaded displays.
85 * The TTY user interface now also displays thread names.
86 * Program-wide, new threads are given descriptive names to aid in
87 debugging and status messages.
88 * Added new module offlineimap/ui/detect.py that is used to detect
89 which user interface to select for a given session. Its operation
90 is governed by the ui config option and the -u command-line option.
91 * Made IMAP folder addmessagesflags() resiliant to a server refusing
92 to return a full set of new message flags. Closes: #152587.
93 * Completely rewrote documentation. OfflineIMAP now has an
94 exhaustive manpage, which is really a manual. It is also shipped
95 in plain text, HTML, PDF, and PostScript formats.
96 * New command-line options:
97 -1 to force no multi-threaded operation
98 -u to force a particular UI
99 -a to specify which accounts to sync
100 -h to print help
101 -c to specify an alternate config file
102 * Added a workaround for UW IMAP problem wherein the server loses
103 uidvalidity whenever a folder is emptied. Now, the program
104 will not consider it a problem if uidvalidity is lost when a folder
105 and the local status cache are both completely empty, since we do
106 not really need to preserve uidvalidity in that case anyway.
107 Closes: #152079.
108
109 -- John Goerzen <jgoerzen@complete.org> Thu, 11 Jul 2002 22:35:42 -0500
110
111 offlineimap (2.0.8) unstable; urgency=low
112
113 * Modified the IMAP folder to use SELECT rather than STATUS more often.
114 Makes the code more robust; handles better with read-only folders;
115 and runs faster, especially for non-threaded useres, where it
116 may eliminate up to 2-3 commands per folder.
117 * Made sure IMAP folder savemessage() does a select. This was a possible
118 bug.
119 * Modified Maildir folder to unlink messages with T flag in
120 cachemessagelist()
121 * My own box now syncs in 3 seconds.
122 * Optimized acquireconnection() to try to give a thread back the
123 connection that it last used, if possible.
124
125 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 23:29:30 -0500
126
127 offlineimap (2.0.7) unstable; urgency=low
128
129 * Fixed imaplib.py to work better with read-only folders.
130
131 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:24:21 -0500
132
133 offlineimap (2.0.6) unstable; urgency=low
134
135 * Added support for holdconnectionopen and keepalive. This feature
136 allows for an IMAP server connection(s) to be held open until
137 the next sync process, permitting faster restart times.
138 * Another try at read-only folder support. This is nasty because I
139 have no way to test it and imaplib's read-only support is weird.
140 * Closing out old bug; fixed in 1.0.2. Closes: #150803.
141 * Optimized algorithm so that a SELECT is never issued for folders
142 that contain no messages.
143
144 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:05:24 -0500
145
146 offlineimap (2.0.5) unstable; urgency=low
147
148 * Fixed a folderfilter example. Partially fixes #152079.
149 * Added folderincludes capability. Partially fixes #152079.
150 * More fixes for read-only folders.
151
152 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:21:52 -0500
153
154 offlineimap (2.0.4) unstable; urgency=low
155
156 * Made OfflineIMAP at least rudimentarily compatible with read-only
157 folders. It will still fail if they get modified locally, though.
158 * Flags are handled case-insensitively. Closes: #151993.
159
160 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:10:29 -0500
161
162 offlineimap (2.0.3) unstable; urgency=low
163
164 * Added support for specifying references. Closes: #151960.
165 * Added -d command-line option to enable imaplib debugging.
166
167 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 20:39:29 -0500
168
169 offlineimap (2.0.2) unstable; urgency=low
170
171 * Added support for remotepassfile. Closes: #151943.
172 * Added support for preauth tunnels.
173
174 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 14:46:23 -0500
175
176 offlineimap (2.0.1) unstable; urgency=low
177
178 * Fixed a bug with not properly propogating foldersep changes.
179 Now, local folders and status folders properly use the foldersep
180 mechanism. This corrects a problem with Exchange servers.
181 * Wrote a major new thread montiring subsystem, defined a new
182 ExitNotifyThread. Handling of Ctrl-C now occurs within 1 second
183 rather than after the whole program terminates. Exceptions that
184 occur in a thread are now caught by the main thread and marshalled
185 over into the UI side of things for dispatch. The entire program will
186 now abort when one thread dies with an exception.
187
188 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 09:07:06 -0500
189
190 offlineimap (2.0.0) unstable; urgency=low
191
192 * This code is now multithreaded. New config file options control the
193 behavior. This can make synchronizing several times faster.
194 * Fixed the STATUS call to be compatible with Exchange.
195 * Added the ability to exclude folders.
196 * If upgrading from 1.0.x, you will need to add maxsyncaccounts to the
197 general section and maxconnections to each account sections.
198 There is also a new folderfilter option.
199 You can find examples of all of these in the new offlineimap.conf
200 example file packaged with the distribution.
201 * The Debian package now properly installs the example offlineimap.conf
202 file.
203 * There is a new mailing list available. To join, send SUBSCRIBE
204 to offlineimap-request@complete.org. The posting address is
205 offlineimap@complete.org.
206
207 -- John Goerzen <jgoerzen@complete.org> Wed, 3 Jul 2002 19:21:32 -0500
208
209 offlineimap (1.0.4) unstable; urgency=low
210
211 * Deletion of more than one message has been optimized. This could make
212 deleting large numbers of messages far faster -- several orders of
213 magnitude.
214 * Moved more sleep code into ui layer. Fancier sleep actions are now
215 possible. Better handling of Ctrl-C in TTY handler.
216
217 -- John Goerzen <jgoerzen@complete.org> Tue, 2 Jul 2002 19:16:04 -0500
218
219 offlineimap (1.0.3) unstable; urgency=low
220
221 * Fixed a bug when a message was deleted on the IMAP side and modified
222 on the local side.
223
224 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 19:08:21 -0500
225
226 offlineimap (1.0.2) unstable; urgency=low
227
228 * Made sure that LocalStatus does writing atomically. If the program
229 is interrupted during save(), there will always be a complete copy of
230 either the old or the new data.
231
232 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 06:57:28 -0500
233
234 offlineimap (1.0.1) unstable; urgency=low
235
236 * Fixed a bug with writing messages to some IMAP servers. Turns
237 out we need to issue CHECK between APPEND and SEARCH for some.
238 Thanks to Donovan Lange for reporting this bug and helping track it
239 down.
240
241 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 22:03:12 -0500
242
243 offlineimap (1.0.0) unstable; urgency=low
244
245 * Initial Release. Closes: #150571.
246
247 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 18:54:56 -0500
248
249 Local variables:
250 mode: debian-changelog
251 End: