]> code.delx.au - offlineimap/blob - offlineimap/head/debian/changelog
/offlineimap/head: changeset 158
[offlineimap] / offlineimap / head / debian / changelog
1 offlineimap (3.0.4) unstable; urgency=low
2
3 * When uploading messages from a Maildir, now convert \r\n to \n in case
4 the message is stored weirdly. That way, everything is uniform.
5 Fixes [complete.org #11].
6 * Manual: added UW IMAPD example with references from docwhat@gerf.org.
7
8 -- John Goerzen <jgoerzen@complete.org> Sun, 21 Jul 2002 16:09:42 -0500
9
10 offlineimap (3.0.3) unstable; urgency=low
11
12 * No longer throws an exception when updating messages with strange
13 Date headers; will just set IMAP Internaldate to the current date.
14 Closes: #153425.
15 * No longer doubles-up reference names for mailboxes. Closes: #153515.
16 * Noted new bug-tracking system in manual and rebuilt manual files.
17 * Now stores incoming messages in 'cur' instead of 'new' if they have
18 the S flag. Closes: #152482.
19
20 -- John Goerzen <jgoerzen@complete.org> Sun, 21 Jul 2002 13:46:13 -0500
21
22 offlineimap (3.0.2) unstable; urgency=low
23
24 * Fixed mailbox name recorder to use localfolder.getvisiblename() rather
25 than remotefolder.getvisiblename()
26 * Fixed remotepassfile option. Closes: #153119. Used 1-line patch from
27 Tommi Virtanen.
28 * Now handles cases of not being able to get UID for an uploaded message
29 more gracefully. This could occur if the server doesn't support
30 SEARCH, can't find the message ID, or finds multiple message IDs.
31 Closes: #153241.
32 * Now source is in Subversion. Make version.py log the Subversion
33 revision number.
34
35 -- John Goerzen <jgoerzen@complete.org> Wed, 15 Jul 2002 06:43:36 -0500
36
37 offlineimap (3.0.1) unstable; urgency=low
38
39 * Detabified the source.
40 * Added UI list to the manpage.
41 * Added -o (run only once) option with patch sent in by Martijn Pieters.
42 * Optimized folder/IMAP.py addmessagesflags() with new listjoin() in
43 imaputil. Now, send the server 1:5,7 instead of 1,2,3,4,5,7.
44 * Made folder/Maildir.py/deletemessage() more tolerant if a message
45 asked to be deleted already has been.
46 * In Base.py/copymessageto(), no longer bother calling getmessage()
47 unless a folder's storemessages() returns true. This will also help
48 with syncing to LocalStatus if the user deleted messages in the
49 Maildir since the cachemessagelist() was called.
50
51 -- John Goerzen <jgoerzen@complete.org> Fri, 12 Jul 2002 07:28:24 -0500
52
53 offlineimap (3.0.0) unstable; urgency=low
54
55 * Introduced a new graphical user interface written with Tkinter.
56 It features a nice view of multi-threaded displays.
57 * The TTY user interface now also displays thread names.
58 * Program-wide, new threads are given descriptive names to aid in
59 debugging and status messages.
60 * Added new module offlineimap/ui/detect.py that is used to detect
61 which user interface to select for a given session. Its operation
62 is governed by the ui config option and the -u command-line option.
63 * Made IMAP folder addmessagesflags() resiliant to a server refusing
64 to return a full set of new message flags. Closes: #152587.
65 * Completely rewrote documentation. OfflineIMAP now has an
66 exhaustive manpage, which is really a manual. It is also shipped
67 in plain text, HTML, PDF, and PostScript formats.
68 * New command-line options:
69 -1 to force no multi-threaded operation
70 -u to force a particular UI
71 -a to specify which accounts to sync
72 -h to print help
73 -c to specify an alternate config file
74 * Added a workaround for UW IMAP problem wherein the server loses
75 uidvalidity whenever a folder is emptied. Now, the program
76 will not consider it a problem if uidvalidity is lost when a folder
77 and the local status cache are both completely empty, since we do
78 not really need to preserve uidvalidity in that case anyway.
79 Closes: #152079.
80
81 -- John Goerzen <jgoerzen@complete.org> Thu, 11 Jul 2002 22:35:42 -0500
82
83 offlineimap (2.0.8) unstable; urgency=low
84
85 * Modified the IMAP folder to use SELECT rather than STATUS more often.
86 Makes the code more robust; handles better with read-only folders;
87 and runs faster, especially for non-threaded useres, where it
88 may eliminate up to 2-3 commands per folder.
89 * Made sure IMAP folder savemessage() does a select. This was a possible
90 bug.
91 * Modified Maildir folder to unlink messages with T flag in
92 cachemessagelist()
93 * My own box now syncs in 3 seconds.
94 * Optimized acquireconnection() to try to give a thread back the
95 connection that it last used, if possible.
96
97 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 23:29:30 -0500
98
99 offlineimap (2.0.7) unstable; urgency=low
100
101 * Fixed imaplib.py to work better with read-only folders.
102
103 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:24:21 -0500
104
105 offlineimap (2.0.6) unstable; urgency=low
106
107 * Added support for holdconnectionopen and keepalive. This feature
108 allows for an IMAP server connection(s) to be held open until
109 the next sync process, permitting faster restart times.
110 * Another try at read-only folder support. This is nasty because I
111 have no way to test it and imaplib's read-only support is weird.
112 * Closing out old bug; fixed in 1.0.2. Closes: #150803.
113 * Optimized algorithm so that a SELECT is never issued for folders
114 that contain no messages.
115
116 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:05:24 -0500
117
118 offlineimap (2.0.5) unstable; urgency=low
119
120 * Fixed a folderfilter example. Partially fixes #152079.
121 * Added folderincludes capability. Partially fixes #152079.
122 * More fixes for read-only folders.
123
124 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:21:52 -0500
125
126 offlineimap (2.0.4) unstable; urgency=low
127
128 * Made OfflineIMAP at least rudimentarily compatible with read-only
129 folders. It will still fail if they get modified locally, though.
130 * Flags are handled case-insensitively. Closes: #151993.
131
132 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:10:29 -0500
133
134 offlineimap (2.0.3) unstable; urgency=low
135
136 * Added support for specifying references. Closes: #151960.
137 * Added -d command-line option to enable imaplib debugging.
138
139 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 20:39:29 -0500
140
141 offlineimap (2.0.2) unstable; urgency=low
142
143 * Added support for remotepassfile. Closes: #151943.
144 * Added support for preauth tunnels.
145
146 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 14:46:23 -0500
147
148 offlineimap (2.0.1) unstable; urgency=low
149
150 * Fixed a bug with not properly propogating foldersep changes.
151 Now, local folders and status folders properly use the foldersep
152 mechanism. This corrects a problem with Exchange servers.
153 * Wrote a major new thread montiring subsystem, defined a new
154 ExitNotifyThread. Handling of Ctrl-C now occurs within 1 second
155 rather than after the whole program terminates. Exceptions that
156 occur in a thread are now caught by the main thread and marshalled
157 over into the UI side of things for dispatch. The entire program will
158 now abort when one thread dies with an exception.
159
160 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 09:07:06 -0500
161
162 offlineimap (2.0.0) unstable; urgency=low
163
164 * This code is now multithreaded. New config file options control the
165 behavior. This can make synchronizing several times faster.
166 * Fixed the STATUS call to be compatible with Exchange.
167 * Added the ability to exclude folders.
168 * If upgrading from 1.0.x, you will need to add maxsyncaccounts to the
169 general section and maxconnections to each account sections.
170 There is also a new folderfilter option.
171 You can find examples of all of these in the new offlineimap.conf
172 example file packaged with the distribution.
173 * The Debian package now properly installs the example offlineimap.conf
174 file.
175 * There is a new mailing list available. To join, send SUBSCRIBE
176 to offlineimap-request@complete.org. The posting address is
177 offlineimap@complete.org.
178
179 -- John Goerzen <jgoerzen@complete.org> Wed, 3 Jul 2002 19:21:32 -0500
180
181 offlineimap (1.0.4) unstable; urgency=low
182
183 * Deletion of more than one message has been optimized. This could make
184 deleting large numbers of messages far faster -- several orders of
185 magnitude.
186 * Moved more sleep code into ui layer. Fancier sleep actions are now
187 possible. Better handling of Ctrl-C in TTY handler.
188
189 -- John Goerzen <jgoerzen@complete.org> Tue, 2 Jul 2002 19:16:04 -0500
190
191 offlineimap (1.0.3) unstable; urgency=low
192
193 * Fixed a bug when a message was deleted on the IMAP side and modified
194 on the local side.
195
196 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 19:08:21 -0500
197
198 offlineimap (1.0.2) unstable; urgency=low
199
200 * Made sure that LocalStatus does writing atomically. If the program
201 is interrupted during save(), there will always be a complete copy of
202 either the old or the new data.
203
204 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 06:57:28 -0500
205
206 offlineimap (1.0.1) unstable; urgency=low
207
208 * Fixed a bug with writing messages to some IMAP servers. Turns
209 out we need to issue CHECK between APPEND and SEARCH for some.
210 Thanks to Donovan Lange for reporting this bug and helping track it
211 down.
212
213 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 22:03:12 -0500
214
215 offlineimap (1.0.0) unstable; urgency=low
216
217 * Initial Release. Closes: #150571.
218
219 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 18:54:56 -0500
220
221 Local variables:
222 mode: debian-changelog
223 End: