]> code.delx.au - offlineimap/blob - offlineimap/head/debian/changelog
/offlineimap/head: changeset 204
[offlineimap] / offlineimap / head / debian / changelog
1 offlineimap (3.2.2) unstable; urgency=low
2
3 * Updated manual to show new Gray color.
4 * Scrolling behavior is better now; sometimes, with fast-scrolling text,
5 the log would stop scrolling.
6
7 -- John Goerzen <jgoerzen@complete.org> Thu, 25 Jul 2002 08:22:25 -0500
8
9 offlineimap (3.2.1) unstable; urgency=low
10
11 * There is a new "connecting" event that will appear in all but the
12 Quiet UIs. It has a gray color in Blinkenlights. This event indicates
13 the the program is connecting to a remote server.
14 * Blinkenlights UI log window is now scrolled and has a new
15 config file option "bufferlines" to specify the size of the scroll
16 buffer.
17 * The Blinkenlights window is now non-resizable when the log is disabled.
18 When the log is enabled, the window is resizable, and the changes in
19 size are reflected in the log widget. Therefore, the Bigger Log
20 and Smaller Log items can disappear, and the Log menu now becomes
21 a Show Log or a Hide Log menu option. No sub-menus necessary anymore.
22 This presents a much cleaner feel, more intuitive operation, and
23 faster navigation.
24 * Fix for account name interpolation in dot warning from 3.2.0 from
25 Martijn Pieters.
26 * Backed out check for . in account names for now. Will put it back in
27 when we have a consensus on what exactly to do. Doubt that anyone
28 has a foldername that would conflict with Blinkenlights anyway.
29 * Fix reading the ui.Tk.Blinkenlights bufferlines option.
30
31 -- John Goerzen <jgoerzen@complete.org> Wed, 24 Jul 2002 17:04:04 -0500
32
33 offlineimap (3.2.0) unstable; urgency=low
34
35 * New BLINKENLIGHTS interface! Mesmerising, isn't it?
36 * New ui.Tk.Blinkenlights section in offlineimap.conf.
37 * New USER INTERFACES section in the manual.
38 * TTYUI isusable() now checks to see if stdout and stdin are TTYs.
39 * Added build-dependency on python2.2-dev. Closes: #154167.
40
41 -- John Goerzen <jgoerzen@complete.org> Wed, 24 Jul 2002 17:53:20 -0500
42
43 offlineimap (3.1.1) unstable; urgency=low
44
45 * Modified imaputil.py and folder/Maildir.py to run faster. Eliminated
46 many regular expressions; pre-compiled many others.
47 * Fixed threadutil's exitnotifyloop to always handle threads in the order
48 they exited, rather than sometimes in the inverse order. This way,
49 make sure to handle thread's exception messages before a thread exited.
50 * Replaced imaplib.py's braindead readline() with a more efficient one.
51 * More optimizations to imaputil and folders for faster operation.
52 * These optimizations, all together, have resulted in OfflineIMAP
53 using approximately half the CPU time of previous versions, fixing
54 [complete.org #6], and... Closes: #153503.
55
56 -- John Goerzen <jgoerzen@complete.org> Wed, 24 Jul 2002 06:53:16 -0500
57
58 offlineimap (3.1.0) unstable; urgency=low
59
60 * When uploading messages from a Maildir, now convert \r\n to \n in case
61 the message is stored weirdly. That way, everything is uniform.
62 Fixes [complete.org #11].
63 * Manual: added UW IMAPD example with references from docwhat@gerf.org.
64 * New UI modules: Noninteractive.Basic and Noninteractive.Quiet.
65 Fixes [complete.org #14].
66 * Added per-thread profiling support to aid in debugging.
67
68 -- John Goerzen <jgoerzen@complete.org> Sun, 21 Jul 2002 16:09:42 -0500
69
70 offlineimap (3.0.3) unstable; urgency=low
71
72 * No longer throws an exception when updating messages with strange
73 Date headers; will just set IMAP Internaldate to the current date.
74 Closes: #153425.
75 * No longer doubles-up reference names for mailboxes. Closes: #153515.
76 * Noted new bug-tracking system in manual and rebuilt manual files.
77 * Now stores incoming messages in 'cur' instead of 'new' if they have
78 the S flag. Closes: #152482.
79
80 -- John Goerzen <jgoerzen@complete.org> Sun, 21 Jul 2002 13:46:13 -0500
81
82 offlineimap (3.0.2) unstable; urgency=low
83
84 * Fixed mailbox name recorder to use localfolder.getvisiblename() rather
85 than remotefolder.getvisiblename()
86 * Fixed remotepassfile option. Closes: #153119. Used 1-line patch from
87 Tommi Virtanen.
88 * Now handles cases of not being able to get UID for an uploaded message
89 more gracefully. This could occur if the server doesn't support
90 SEARCH, can't find the message ID, or finds multiple message IDs.
91 Closes: #153241.
92 * Now source is in Subversion. Make version.py log the Subversion
93 revision number.
94
95 -- John Goerzen <jgoerzen@complete.org> Wed, 15 Jul 2002 06:43:36 -0500
96
97 offlineimap (3.0.1) unstable; urgency=low
98
99 * Detabified the source.
100 * Added UI list to the manpage.
101 * Added -o (run only once) option with patch sent in by Martijn Pieters.
102 * Optimized folder/IMAP.py addmessagesflags() with new listjoin() in
103 imaputil. Now, send the server 1:5,7 instead of 1,2,3,4,5,7.
104 * Made folder/Maildir.py/deletemessage() more tolerant if a message
105 asked to be deleted already has been.
106 * In Base.py/copymessageto(), no longer bother calling getmessage()
107 unless a folder's storemessages() returns true. This will also help
108 with syncing to LocalStatus if the user deleted messages in the
109 Maildir since the cachemessagelist() was called.
110
111 -- John Goerzen <jgoerzen@complete.org> Fri, 12 Jul 2002 07:28:24 -0500
112
113 offlineimap (3.0.0) unstable; urgency=low
114
115 * Introduced a new graphical user interface written with Tkinter.
116 It features a nice view of multi-threaded displays.
117 * The TTY user interface now also displays thread names.
118 * Program-wide, new threads are given descriptive names to aid in
119 debugging and status messages.
120 * Added new module offlineimap/ui/detect.py that is used to detect
121 which user interface to select for a given session. Its operation
122 is governed by the ui config option and the -u command-line option.
123 * Made IMAP folder addmessagesflags() resiliant to a server refusing
124 to return a full set of new message flags. Closes: #152587.
125 * Completely rewrote documentation. OfflineIMAP now has an
126 exhaustive manpage, which is really a manual. It is also shipped
127 in plain text, HTML, PDF, and PostScript formats.
128 * New command-line options:
129 -1 to force no multi-threaded operation
130 -u to force a particular UI
131 -a to specify which accounts to sync
132 -h to print help
133 -c to specify an alternate config file
134 * Added a workaround for UW IMAP problem wherein the server loses
135 uidvalidity whenever a folder is emptied. Now, the program
136 will not consider it a problem if uidvalidity is lost when a folder
137 and the local status cache are both completely empty, since we do
138 not really need to preserve uidvalidity in that case anyway.
139 Closes: #152079.
140
141 -- John Goerzen <jgoerzen@complete.org> Thu, 11 Jul 2002 22:35:42 -0500
142
143 offlineimap (2.0.8) unstable; urgency=low
144
145 * Modified the IMAP folder to use SELECT rather than STATUS more often.
146 Makes the code more robust; handles better with read-only folders;
147 and runs faster, especially for non-threaded useres, where it
148 may eliminate up to 2-3 commands per folder.
149 * Made sure IMAP folder savemessage() does a select. This was a possible
150 bug.
151 * Modified Maildir folder to unlink messages with T flag in
152 cachemessagelist()
153 * My own box now syncs in 3 seconds.
154 * Optimized acquireconnection() to try to give a thread back the
155 connection that it last used, if possible.
156
157 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 23:29:30 -0500
158
159 offlineimap (2.0.7) unstable; urgency=low
160
161 * Fixed imaplib.py to work better with read-only folders.
162
163 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:24:21 -0500
164
165 offlineimap (2.0.6) unstable; urgency=low
166
167 * Added support for holdconnectionopen and keepalive. This feature
168 allows for an IMAP server connection(s) to be held open until
169 the next sync process, permitting faster restart times.
170 * Another try at read-only folder support. This is nasty because I
171 have no way to test it and imaplib's read-only support is weird.
172 * Closing out old bug; fixed in 1.0.2. Closes: #150803.
173 * Optimized algorithm so that a SELECT is never issued for folders
174 that contain no messages.
175
176 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:05:24 -0500
177
178 offlineimap (2.0.5) unstable; urgency=low
179
180 * Fixed a folderfilter example. Partially fixes #152079.
181 * Added folderincludes capability. Partially fixes #152079.
182 * More fixes for read-only folders.
183
184 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:21:52 -0500
185
186 offlineimap (2.0.4) unstable; urgency=low
187
188 * Made OfflineIMAP at least rudimentarily compatible with read-only
189 folders. It will still fail if they get modified locally, though.
190 * Flags are handled case-insensitively. Closes: #151993.
191
192 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:10:29 -0500
193
194 offlineimap (2.0.3) unstable; urgency=low
195
196 * Added support for specifying references. Closes: #151960.
197 * Added -d command-line option to enable imaplib debugging.
198
199 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 20:39:29 -0500
200
201 offlineimap (2.0.2) unstable; urgency=low
202
203 * Added support for remotepassfile. Closes: #151943.
204 * Added support for preauth tunnels.
205
206 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 14:46:23 -0500
207
208 offlineimap (2.0.1) unstable; urgency=low
209
210 * Fixed a bug with not properly propogating foldersep changes.
211 Now, local folders and status folders properly use the foldersep
212 mechanism. This corrects a problem with Exchange servers.
213 * Wrote a major new thread montiring subsystem, defined a new
214 ExitNotifyThread. Handling of Ctrl-C now occurs within 1 second
215 rather than after the whole program terminates. Exceptions that
216 occur in a thread are now caught by the main thread and marshalled
217 over into the UI side of things for dispatch. The entire program will
218 now abort when one thread dies with an exception.
219
220 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 09:07:06 -0500
221
222 offlineimap (2.0.0) unstable; urgency=low
223
224 * This code is now multithreaded. New config file options control the
225 behavior. This can make synchronizing several times faster.
226 * Fixed the STATUS call to be compatible with Exchange.
227 * Added the ability to exclude folders.
228 * If upgrading from 1.0.x, you will need to add maxsyncaccounts to the
229 general section and maxconnections to each account sections.
230 There is also a new folderfilter option.
231 You can find examples of all of these in the new offlineimap.conf
232 example file packaged with the distribution.
233 * The Debian package now properly installs the example offlineimap.conf
234 file.
235 * There is a new mailing list available. To join, send SUBSCRIBE
236 to offlineimap-request@complete.org. The posting address is
237 offlineimap@complete.org.
238
239 -- John Goerzen <jgoerzen@complete.org> Wed, 3 Jul 2002 19:21:32 -0500
240
241 offlineimap (1.0.4) unstable; urgency=low
242
243 * Deletion of more than one message has been optimized. This could make
244 deleting large numbers of messages far faster -- several orders of
245 magnitude.
246 * Moved more sleep code into ui layer. Fancier sleep actions are now
247 possible. Better handling of Ctrl-C in TTY handler.
248
249 -- John Goerzen <jgoerzen@complete.org> Tue, 2 Jul 2002 19:16:04 -0500
250
251 offlineimap (1.0.3) unstable; urgency=low
252
253 * Fixed a bug when a message was deleted on the IMAP side and modified
254 on the local side.
255
256 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 19:08:21 -0500
257
258 offlineimap (1.0.2) unstable; urgency=low
259
260 * Made sure that LocalStatus does writing atomically. If the program
261 is interrupted during save(), there will always be a complete copy of
262 either the old or the new data.
263
264 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 06:57:28 -0500
265
266 offlineimap (1.0.1) unstable; urgency=low
267
268 * Fixed a bug with writing messages to some IMAP servers. Turns
269 out we need to issue CHECK between APPEND and SEARCH for some.
270 Thanks to Donovan Lange for reporting this bug and helping track it
271 down.
272
273 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 22:03:12 -0500
274
275 offlineimap (1.0.0) unstable; urgency=low
276
277 * Initial Release. Closes: #150571.
278
279 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 18:54:56 -0500
280
281 Local variables:
282 mode: debian-changelog
283 End: