]> code.delx.au - offlineimap/blob - offlineimap/head/debian/changelog
/offlineimap/head: changeset 200
[offlineimap] / offlineimap / head / debian / changelog
1 offlineimap (3.2.1) unstable; urgency=low
2
3 * There is a new "connecting" event that will appear in all but the
4 Quiet UIs. It has a gray color in Blinkenlights. This event indicates
5 the the program is connecting to a remote server.
6 * Blinkenlights UI log window is now scrolled and has a new
7 config file option "bufferlines" to specify the size of the scroll
8 buffer.
9 * The Blinkenlights window is now non-resizable when the log is disabled.
10 When the log is enabled, the window is resizable, and the changes in
11 size are reflected in the log widget. Therefore, the Bigger Log
12 and Smaller Log items can disappear, and the Log menu now becomes
13 a Show Log or a Hide Log menu option. No sub-menus necessary anymore.
14 This presents a much cleaner feel, more intuitive operation, and
15 faster navigation.
16 * Fix for account name interpolation in dot warning from 3.2.0 from
17 Martijn Pieters.
18 * Backed out check for . in account names for now. Will put it back in
19 when we have a consensus on what exactly to do. Doubt that anyone
20 has a foldername that would conflict with Blinkenlights anyway.
21 * Fix reading the ui.Tk.Blinkenlights bufferlines option.
22
23 -- John Goerzen <jgoerzen@complete.org> Wed, 24 Jul 2002 17:04:04 -0500
24
25 offlineimap (3.2.0) unstable; urgency=low
26
27 * New BLINKENLIGHTS interface! Mesmerising, isn't it?
28 * New ui.Tk.Blinkenlights section in offlineimap.conf.
29 * New USER INTERFACES section in the manual.
30 * TTYUI isusable() now checks to see if stdout and stdin are TTYs.
31 * Added build-dependency on python2.2-dev. Closes: #154167.
32
33 -- John Goerzen <jgoerzen@complete.org> Wed, 24 Jul 2002 17:53:20 -0500
34
35 offlineimap (3.1.1) unstable; urgency=low
36
37 * Modified imaputil.py and folder/Maildir.py to run faster. Eliminated
38 many regular expressions; pre-compiled many others.
39 * Fixed threadutil's exitnotifyloop to always handle threads in the order
40 they exited, rather than sometimes in the inverse order. This way,
41 make sure to handle thread's exception messages before a thread exited.
42 * Replaced imaplib.py's braindead readline() with a more efficient one.
43 * More optimizations to imaputil and folders for faster operation.
44 * These optimizations, all together, have resulted in OfflineIMAP
45 using approximately half the CPU time of previous versions, fixing
46 [complete.org #6], and... Closes: #153503.
47
48 -- John Goerzen <jgoerzen@complete.org> Wed, 24 Jul 2002 06:53:16 -0500
49
50 offlineimap (3.1.0) unstable; urgency=low
51
52 * When uploading messages from a Maildir, now convert \r\n to \n in case
53 the message is stored weirdly. That way, everything is uniform.
54 Fixes [complete.org #11].
55 * Manual: added UW IMAPD example with references from docwhat@gerf.org.
56 * New UI modules: Noninteractive.Basic and Noninteractive.Quiet.
57 Fixes [complete.org #14].
58 * Added per-thread profiling support to aid in debugging.
59
60 -- John Goerzen <jgoerzen@complete.org> Sun, 21 Jul 2002 16:09:42 -0500
61
62 offlineimap (3.0.3) unstable; urgency=low
63
64 * No longer throws an exception when updating messages with strange
65 Date headers; will just set IMAP Internaldate to the current date.
66 Closes: #153425.
67 * No longer doubles-up reference names for mailboxes. Closes: #153515.
68 * Noted new bug-tracking system in manual and rebuilt manual files.
69 * Now stores incoming messages in 'cur' instead of 'new' if they have
70 the S flag. Closes: #152482.
71
72 -- John Goerzen <jgoerzen@complete.org> Sun, 21 Jul 2002 13:46:13 -0500
73
74 offlineimap (3.0.2) unstable; urgency=low
75
76 * Fixed mailbox name recorder to use localfolder.getvisiblename() rather
77 than remotefolder.getvisiblename()
78 * Fixed remotepassfile option. Closes: #153119. Used 1-line patch from
79 Tommi Virtanen.
80 * Now handles cases of not being able to get UID for an uploaded message
81 more gracefully. This could occur if the server doesn't support
82 SEARCH, can't find the message ID, or finds multiple message IDs.
83 Closes: #153241.
84 * Now source is in Subversion. Make version.py log the Subversion
85 revision number.
86
87 -- John Goerzen <jgoerzen@complete.org> Wed, 15 Jul 2002 06:43:36 -0500
88
89 offlineimap (3.0.1) unstable; urgency=low
90
91 * Detabified the source.
92 * Added UI list to the manpage.
93 * Added -o (run only once) option with patch sent in by Martijn Pieters.
94 * Optimized folder/IMAP.py addmessagesflags() with new listjoin() in
95 imaputil. Now, send the server 1:5,7 instead of 1,2,3,4,5,7.
96 * Made folder/Maildir.py/deletemessage() more tolerant if a message
97 asked to be deleted already has been.
98 * In Base.py/copymessageto(), no longer bother calling getmessage()
99 unless a folder's storemessages() returns true. This will also help
100 with syncing to LocalStatus if the user deleted messages in the
101 Maildir since the cachemessagelist() was called.
102
103 -- John Goerzen <jgoerzen@complete.org> Fri, 12 Jul 2002 07:28:24 -0500
104
105 offlineimap (3.0.0) unstable; urgency=low
106
107 * Introduced a new graphical user interface written with Tkinter.
108 It features a nice view of multi-threaded displays.
109 * The TTY user interface now also displays thread names.
110 * Program-wide, new threads are given descriptive names to aid in
111 debugging and status messages.
112 * Added new module offlineimap/ui/detect.py that is used to detect
113 which user interface to select for a given session. Its operation
114 is governed by the ui config option and the -u command-line option.
115 * Made IMAP folder addmessagesflags() resiliant to a server refusing
116 to return a full set of new message flags. Closes: #152587.
117 * Completely rewrote documentation. OfflineIMAP now has an
118 exhaustive manpage, which is really a manual. It is also shipped
119 in plain text, HTML, PDF, and PostScript formats.
120 * New command-line options:
121 -1 to force no multi-threaded operation
122 -u to force a particular UI
123 -a to specify which accounts to sync
124 -h to print help
125 -c to specify an alternate config file
126 * Added a workaround for UW IMAP problem wherein the server loses
127 uidvalidity whenever a folder is emptied. Now, the program
128 will not consider it a problem if uidvalidity is lost when a folder
129 and the local status cache are both completely empty, since we do
130 not really need to preserve uidvalidity in that case anyway.
131 Closes: #152079.
132
133 -- John Goerzen <jgoerzen@complete.org> Thu, 11 Jul 2002 22:35:42 -0500
134
135 offlineimap (2.0.8) unstable; urgency=low
136
137 * Modified the IMAP folder to use SELECT rather than STATUS more often.
138 Makes the code more robust; handles better with read-only folders;
139 and runs faster, especially for non-threaded useres, where it
140 may eliminate up to 2-3 commands per folder.
141 * Made sure IMAP folder savemessage() does a select. This was a possible
142 bug.
143 * Modified Maildir folder to unlink messages with T flag in
144 cachemessagelist()
145 * My own box now syncs in 3 seconds.
146 * Optimized acquireconnection() to try to give a thread back the
147 connection that it last used, if possible.
148
149 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 23:29:30 -0500
150
151 offlineimap (2.0.7) unstable; urgency=low
152
153 * Fixed imaplib.py to work better with read-only folders.
154
155 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:24:21 -0500
156
157 offlineimap (2.0.6) unstable; urgency=low
158
159 * Added support for holdconnectionopen and keepalive. This feature
160 allows for an IMAP server connection(s) to be held open until
161 the next sync process, permitting faster restart times.
162 * Another try at read-only folder support. This is nasty because I
163 have no way to test it and imaplib's read-only support is weird.
164 * Closing out old bug; fixed in 1.0.2. Closes: #150803.
165 * Optimized algorithm so that a SELECT is never issued for folders
166 that contain no messages.
167
168 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:05:24 -0500
169
170 offlineimap (2.0.5) unstable; urgency=low
171
172 * Fixed a folderfilter example. Partially fixes #152079.
173 * Added folderincludes capability. Partially fixes #152079.
174 * More fixes for read-only folders.
175
176 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:21:52 -0500
177
178 offlineimap (2.0.4) unstable; urgency=low
179
180 * Made OfflineIMAP at least rudimentarily compatible with read-only
181 folders. It will still fail if they get modified locally, though.
182 * Flags are handled case-insensitively. Closes: #151993.
183
184 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:10:29 -0500
185
186 offlineimap (2.0.3) unstable; urgency=low
187
188 * Added support for specifying references. Closes: #151960.
189 * Added -d command-line option to enable imaplib debugging.
190
191 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 20:39:29 -0500
192
193 offlineimap (2.0.2) unstable; urgency=low
194
195 * Added support for remotepassfile. Closes: #151943.
196 * Added support for preauth tunnels.
197
198 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 14:46:23 -0500
199
200 offlineimap (2.0.1) unstable; urgency=low
201
202 * Fixed a bug with not properly propogating foldersep changes.
203 Now, local folders and status folders properly use the foldersep
204 mechanism. This corrects a problem with Exchange servers.
205 * Wrote a major new thread montiring subsystem, defined a new
206 ExitNotifyThread. Handling of Ctrl-C now occurs within 1 second
207 rather than after the whole program terminates. Exceptions that
208 occur in a thread are now caught by the main thread and marshalled
209 over into the UI side of things for dispatch. The entire program will
210 now abort when one thread dies with an exception.
211
212 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 09:07:06 -0500
213
214 offlineimap (2.0.0) unstable; urgency=low
215
216 * This code is now multithreaded. New config file options control the
217 behavior. This can make synchronizing several times faster.
218 * Fixed the STATUS call to be compatible with Exchange.
219 * Added the ability to exclude folders.
220 * If upgrading from 1.0.x, you will need to add maxsyncaccounts to the
221 general section and maxconnections to each account sections.
222 There is also a new folderfilter option.
223 You can find examples of all of these in the new offlineimap.conf
224 example file packaged with the distribution.
225 * The Debian package now properly installs the example offlineimap.conf
226 file.
227 * There is a new mailing list available. To join, send SUBSCRIBE
228 to offlineimap-request@complete.org. The posting address is
229 offlineimap@complete.org.
230
231 -- John Goerzen <jgoerzen@complete.org> Wed, 3 Jul 2002 19:21:32 -0500
232
233 offlineimap (1.0.4) unstable; urgency=low
234
235 * Deletion of more than one message has been optimized. This could make
236 deleting large numbers of messages far faster -- several orders of
237 magnitude.
238 * Moved more sleep code into ui layer. Fancier sleep actions are now
239 possible. Better handling of Ctrl-C in TTY handler.
240
241 -- John Goerzen <jgoerzen@complete.org> Tue, 2 Jul 2002 19:16:04 -0500
242
243 offlineimap (1.0.3) unstable; urgency=low
244
245 * Fixed a bug when a message was deleted on the IMAP side and modified
246 on the local side.
247
248 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 19:08:21 -0500
249
250 offlineimap (1.0.2) unstable; urgency=low
251
252 * Made sure that LocalStatus does writing atomically. If the program
253 is interrupted during save(), there will always be a complete copy of
254 either the old or the new data.
255
256 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 06:57:28 -0500
257
258 offlineimap (1.0.1) unstable; urgency=low
259
260 * Fixed a bug with writing messages to some IMAP servers. Turns
261 out we need to issue CHECK between APPEND and SEARCH for some.
262 Thanks to Donovan Lange for reporting this bug and helping track it
263 down.
264
265 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 22:03:12 -0500
266
267 offlineimap (1.0.0) unstable; urgency=low
268
269 * Initial Release. Closes: #150571.
270
271 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 18:54:56 -0500
272
273 Local variables:
274 mode: debian-changelog
275 End: