]> code.delx.au - offlineimap/blob - offlineimap/head/debian/changelog
/offlineimap/head: changeset 178
[offlineimap] / offlineimap / head / debian / changelog
1 offlineimap (3.2.0) unstable; urgency=low
2
3 * New BLINKENLIGHTS interface!
4
5 -- John Goerzen <jgoerzen@complete.org> Wed, 24 Jul 2002 07:53:20 -0500
6
7 offlineimap (3.1.1) unstable; urgency=low
8
9 * Modified imaputil.py and folder/Maildir.py to run faster. Eliminated
10 many regular expressions; pre-compiled many others.
11 * Fixed threadutil's exitnotifyloop to always handle threads in the order
12 they exited, rather than sometimes in the inverse order. This way,
13 make sure to handle thread's exception messages before a thread exited.
14 * Replaced imaplib.py's braindead readline() with a more efficient one.
15 * More optimizations to imaputil and folders for faster operation.
16 * These optimizations, all together, have resulted in OfflineIMAP
17 using approximately half the CPU time of previous versions, fixing
18 [complete.org #6], and... Closes: #153503.
19
20 -- John Goerzen <jgoerzen@complete.org> Wed, 24 Jul 2002 06:53:16 -0500
21
22 offlineimap (3.1.0) unstable; urgency=low
23
24 * When uploading messages from a Maildir, now convert \r\n to \n in case
25 the message is stored weirdly. That way, everything is uniform.
26 Fixes [complete.org #11].
27 * Manual: added UW IMAPD example with references from docwhat@gerf.org.
28 * New UI modules: Noninteractive.Basic and Noninteractive.Quiet.
29 Fixes [complete.org #14].
30 * Added per-thread profiling support to aid in debugging.
31
32 -- John Goerzen <jgoerzen@complete.org> Sun, 21 Jul 2002 16:09:42 -0500
33
34 offlineimap (3.0.3) unstable; urgency=low
35
36 * No longer throws an exception when updating messages with strange
37 Date headers; will just set IMAP Internaldate to the current date.
38 Closes: #153425.
39 * No longer doubles-up reference names for mailboxes. Closes: #153515.
40 * Noted new bug-tracking system in manual and rebuilt manual files.
41 * Now stores incoming messages in 'cur' instead of 'new' if they have
42 the S flag. Closes: #152482.
43
44 -- John Goerzen <jgoerzen@complete.org> Sun, 21 Jul 2002 13:46:13 -0500
45
46 offlineimap (3.0.2) unstable; urgency=low
47
48 * Fixed mailbox name recorder to use localfolder.getvisiblename() rather
49 than remotefolder.getvisiblename()
50 * Fixed remotepassfile option. Closes: #153119. Used 1-line patch from
51 Tommi Virtanen.
52 * Now handles cases of not being able to get UID for an uploaded message
53 more gracefully. This could occur if the server doesn't support
54 SEARCH, can't find the message ID, or finds multiple message IDs.
55 Closes: #153241.
56 * Now source is in Subversion. Make version.py log the Subversion
57 revision number.
58
59 -- John Goerzen <jgoerzen@complete.org> Wed, 15 Jul 2002 06:43:36 -0500
60
61 offlineimap (3.0.1) unstable; urgency=low
62
63 * Detabified the source.
64 * Added UI list to the manpage.
65 * Added -o (run only once) option with patch sent in by Martijn Pieters.
66 * Optimized folder/IMAP.py addmessagesflags() with new listjoin() in
67 imaputil. Now, send the server 1:5,7 instead of 1,2,3,4,5,7.
68 * Made folder/Maildir.py/deletemessage() more tolerant if a message
69 asked to be deleted already has been.
70 * In Base.py/copymessageto(), no longer bother calling getmessage()
71 unless a folder's storemessages() returns true. This will also help
72 with syncing to LocalStatus if the user deleted messages in the
73 Maildir since the cachemessagelist() was called.
74
75 -- John Goerzen <jgoerzen@complete.org> Fri, 12 Jul 2002 07:28:24 -0500
76
77 offlineimap (3.0.0) unstable; urgency=low
78
79 * Introduced a new graphical user interface written with Tkinter.
80 It features a nice view of multi-threaded displays.
81 * The TTY user interface now also displays thread names.
82 * Program-wide, new threads are given descriptive names to aid in
83 debugging and status messages.
84 * Added new module offlineimap/ui/detect.py that is used to detect
85 which user interface to select for a given session. Its operation
86 is governed by the ui config option and the -u command-line option.
87 * Made IMAP folder addmessagesflags() resiliant to a server refusing
88 to return a full set of new message flags. Closes: #152587.
89 * Completely rewrote documentation. OfflineIMAP now has an
90 exhaustive manpage, which is really a manual. It is also shipped
91 in plain text, HTML, PDF, and PostScript formats.
92 * New command-line options:
93 -1 to force no multi-threaded operation
94 -u to force a particular UI
95 -a to specify which accounts to sync
96 -h to print help
97 -c to specify an alternate config file
98 * Added a workaround for UW IMAP problem wherein the server loses
99 uidvalidity whenever a folder is emptied. Now, the program
100 will not consider it a problem if uidvalidity is lost when a folder
101 and the local status cache are both completely empty, since we do
102 not really need to preserve uidvalidity in that case anyway.
103 Closes: #152079.
104
105 -- John Goerzen <jgoerzen@complete.org> Thu, 11 Jul 2002 22:35:42 -0500
106
107 offlineimap (2.0.8) unstable; urgency=low
108
109 * Modified the IMAP folder to use SELECT rather than STATUS more often.
110 Makes the code more robust; handles better with read-only folders;
111 and runs faster, especially for non-threaded useres, where it
112 may eliminate up to 2-3 commands per folder.
113 * Made sure IMAP folder savemessage() does a select. This was a possible
114 bug.
115 * Modified Maildir folder to unlink messages with T flag in
116 cachemessagelist()
117 * My own box now syncs in 3 seconds.
118 * Optimized acquireconnection() to try to give a thread back the
119 connection that it last used, if possible.
120
121 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 23:29:30 -0500
122
123 offlineimap (2.0.7) unstable; urgency=low
124
125 * Fixed imaplib.py to work better with read-only folders.
126
127 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:24:21 -0500
128
129 offlineimap (2.0.6) unstable; urgency=low
130
131 * Added support for holdconnectionopen and keepalive. This feature
132 allows for an IMAP server connection(s) to be held open until
133 the next sync process, permitting faster restart times.
134 * Another try at read-only folder support. This is nasty because I
135 have no way to test it and imaplib's read-only support is weird.
136 * Closing out old bug; fixed in 1.0.2. Closes: #150803.
137 * Optimized algorithm so that a SELECT is never issued for folders
138 that contain no messages.
139
140 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:05:24 -0500
141
142 offlineimap (2.0.5) unstable; urgency=low
143
144 * Fixed a folderfilter example. Partially fixes #152079.
145 * Added folderincludes capability. Partially fixes #152079.
146 * More fixes for read-only folders.
147
148 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:21:52 -0500
149
150 offlineimap (2.0.4) unstable; urgency=low
151
152 * Made OfflineIMAP at least rudimentarily compatible with read-only
153 folders. It will still fail if they get modified locally, though.
154 * Flags are handled case-insensitively. Closes: #151993.
155
156 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:10:29 -0500
157
158 offlineimap (2.0.3) unstable; urgency=low
159
160 * Added support for specifying references. Closes: #151960.
161 * Added -d command-line option to enable imaplib debugging.
162
163 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 20:39:29 -0500
164
165 offlineimap (2.0.2) unstable; urgency=low
166
167 * Added support for remotepassfile. Closes: #151943.
168 * Added support for preauth tunnels.
169
170 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 14:46:23 -0500
171
172 offlineimap (2.0.1) unstable; urgency=low
173
174 * Fixed a bug with not properly propogating foldersep changes.
175 Now, local folders and status folders properly use the foldersep
176 mechanism. This corrects a problem with Exchange servers.
177 * Wrote a major new thread montiring subsystem, defined a new
178 ExitNotifyThread. Handling of Ctrl-C now occurs within 1 second
179 rather than after the whole program terminates. Exceptions that
180 occur in a thread are now caught by the main thread and marshalled
181 over into the UI side of things for dispatch. The entire program will
182 now abort when one thread dies with an exception.
183
184 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 09:07:06 -0500
185
186 offlineimap (2.0.0) unstable; urgency=low
187
188 * This code is now multithreaded. New config file options control the
189 behavior. This can make synchronizing several times faster.
190 * Fixed the STATUS call to be compatible with Exchange.
191 * Added the ability to exclude folders.
192 * If upgrading from 1.0.x, you will need to add maxsyncaccounts to the
193 general section and maxconnections to each account sections.
194 There is also a new folderfilter option.
195 You can find examples of all of these in the new offlineimap.conf
196 example file packaged with the distribution.
197 * The Debian package now properly installs the example offlineimap.conf
198 file.
199 * There is a new mailing list available. To join, send SUBSCRIBE
200 to offlineimap-request@complete.org. The posting address is
201 offlineimap@complete.org.
202
203 -- John Goerzen <jgoerzen@complete.org> Wed, 3 Jul 2002 19:21:32 -0500
204
205 offlineimap (1.0.4) unstable; urgency=low
206
207 * Deletion of more than one message has been optimized. This could make
208 deleting large numbers of messages far faster -- several orders of
209 magnitude.
210 * Moved more sleep code into ui layer. Fancier sleep actions are now
211 possible. Better handling of Ctrl-C in TTY handler.
212
213 -- John Goerzen <jgoerzen@complete.org> Tue, 2 Jul 2002 19:16:04 -0500
214
215 offlineimap (1.0.3) unstable; urgency=low
216
217 * Fixed a bug when a message was deleted on the IMAP side and modified
218 on the local side.
219
220 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 19:08:21 -0500
221
222 offlineimap (1.0.2) unstable; urgency=low
223
224 * Made sure that LocalStatus does writing atomically. If the program
225 is interrupted during save(), there will always be a complete copy of
226 either the old or the new data.
227
228 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 06:57:28 -0500
229
230 offlineimap (1.0.1) unstable; urgency=low
231
232 * Fixed a bug with writing messages to some IMAP servers. Turns
233 out we need to issue CHECK between APPEND and SEARCH for some.
234 Thanks to Donovan Lange for reporting this bug and helping track it
235 down.
236
237 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 22:03:12 -0500
238
239 offlineimap (1.0.0) unstable; urgency=low
240
241 * Initial Release. Closes: #150571.
242
243 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 18:54:56 -0500
244
245 Local variables:
246 mode: debian-changelog
247 End: