]> code.delx.au - offlineimap/blob - offlineimap/head/debian/changelog
/offlineimap/head: changeset 164
[offlineimap] / offlineimap / head / debian / changelog
1 offlineimap (3.0.4) unstable; urgency=low
2
3 * When uploading messages from a Maildir, now convert \r\n to \n in case
4 the message is stored weirdly. That way, everything is uniform.
5 Fixes [complete.org #11].
6 * Manual: added UW IMAPD example with references from docwhat@gerf.org.
7 * New UI modules: Noninteractive.Basic and Noninteractive.Quiet.
8 Fixes [complete.org #14].
9 * Added per-thread profiling support to aid in debugging.
10
11 -- John Goerzen <jgoerzen@complete.org> Sun, 21 Jul 2002 16:09:42 -0500
12
13 offlineimap (3.0.3) unstable; urgency=low
14
15 * No longer throws an exception when updating messages with strange
16 Date headers; will just set IMAP Internaldate to the current date.
17 Closes: #153425.
18 * No longer doubles-up reference names for mailboxes. Closes: #153515.
19 * Noted new bug-tracking system in manual and rebuilt manual files.
20 * Now stores incoming messages in 'cur' instead of 'new' if they have
21 the S flag. Closes: #152482.
22
23 -- John Goerzen <jgoerzen@complete.org> Sun, 21 Jul 2002 13:46:13 -0500
24
25 offlineimap (3.0.2) unstable; urgency=low
26
27 * Fixed mailbox name recorder to use localfolder.getvisiblename() rather
28 than remotefolder.getvisiblename()
29 * Fixed remotepassfile option. Closes: #153119. Used 1-line patch from
30 Tommi Virtanen.
31 * Now handles cases of not being able to get UID for an uploaded message
32 more gracefully. This could occur if the server doesn't support
33 SEARCH, can't find the message ID, or finds multiple message IDs.
34 Closes: #153241.
35 * Now source is in Subversion. Make version.py log the Subversion
36 revision number.
37
38 -- John Goerzen <jgoerzen@complete.org> Wed, 15 Jul 2002 06:43:36 -0500
39
40 offlineimap (3.0.1) unstable; urgency=low
41
42 * Detabified the source.
43 * Added UI list to the manpage.
44 * Added -o (run only once) option with patch sent in by Martijn Pieters.
45 * Optimized folder/IMAP.py addmessagesflags() with new listjoin() in
46 imaputil. Now, send the server 1:5,7 instead of 1,2,3,4,5,7.
47 * Made folder/Maildir.py/deletemessage() more tolerant if a message
48 asked to be deleted already has been.
49 * In Base.py/copymessageto(), no longer bother calling getmessage()
50 unless a folder's storemessages() returns true. This will also help
51 with syncing to LocalStatus if the user deleted messages in the
52 Maildir since the cachemessagelist() was called.
53
54 -- John Goerzen <jgoerzen@complete.org> Fri, 12 Jul 2002 07:28:24 -0500
55
56 offlineimap (3.0.0) unstable; urgency=low
57
58 * Introduced a new graphical user interface written with Tkinter.
59 It features a nice view of multi-threaded displays.
60 * The TTY user interface now also displays thread names.
61 * Program-wide, new threads are given descriptive names to aid in
62 debugging and status messages.
63 * Added new module offlineimap/ui/detect.py that is used to detect
64 which user interface to select for a given session. Its operation
65 is governed by the ui config option and the -u command-line option.
66 * Made IMAP folder addmessagesflags() resiliant to a server refusing
67 to return a full set of new message flags. Closes: #152587.
68 * Completely rewrote documentation. OfflineIMAP now has an
69 exhaustive manpage, which is really a manual. It is also shipped
70 in plain text, HTML, PDF, and PostScript formats.
71 * New command-line options:
72 -1 to force no multi-threaded operation
73 -u to force a particular UI
74 -a to specify which accounts to sync
75 -h to print help
76 -c to specify an alternate config file
77 * Added a workaround for UW IMAP problem wherein the server loses
78 uidvalidity whenever a folder is emptied. Now, the program
79 will not consider it a problem if uidvalidity is lost when a folder
80 and the local status cache are both completely empty, since we do
81 not really need to preserve uidvalidity in that case anyway.
82 Closes: #152079.
83
84 -- John Goerzen <jgoerzen@complete.org> Thu, 11 Jul 2002 22:35:42 -0500
85
86 offlineimap (2.0.8) unstable; urgency=low
87
88 * Modified the IMAP folder to use SELECT rather than STATUS more often.
89 Makes the code more robust; handles better with read-only folders;
90 and runs faster, especially for non-threaded useres, where it
91 may eliminate up to 2-3 commands per folder.
92 * Made sure IMAP folder savemessage() does a select. This was a possible
93 bug.
94 * Modified Maildir folder to unlink messages with T flag in
95 cachemessagelist()
96 * My own box now syncs in 3 seconds.
97 * Optimized acquireconnection() to try to give a thread back the
98 connection that it last used, if possible.
99
100 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 23:29:30 -0500
101
102 offlineimap (2.0.7) unstable; urgency=low
103
104 * Fixed imaplib.py to work better with read-only folders.
105
106 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:24:21 -0500
107
108 offlineimap (2.0.6) unstable; urgency=low
109
110 * Added support for holdconnectionopen and keepalive. This feature
111 allows for an IMAP server connection(s) to be held open until
112 the next sync process, permitting faster restart times.
113 * Another try at read-only folder support. This is nasty because I
114 have no way to test it and imaplib's read-only support is weird.
115 * Closing out old bug; fixed in 1.0.2. Closes: #150803.
116 * Optimized algorithm so that a SELECT is never issued for folders
117 that contain no messages.
118
119 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:05:24 -0500
120
121 offlineimap (2.0.5) unstable; urgency=low
122
123 * Fixed a folderfilter example. Partially fixes #152079.
124 * Added folderincludes capability. Partially fixes #152079.
125 * More fixes for read-only folders.
126
127 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:21:52 -0500
128
129 offlineimap (2.0.4) unstable; urgency=low
130
131 * Made OfflineIMAP at least rudimentarily compatible with read-only
132 folders. It will still fail if they get modified locally, though.
133 * Flags are handled case-insensitively. Closes: #151993.
134
135 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:10:29 -0500
136
137 offlineimap (2.0.3) unstable; urgency=low
138
139 * Added support for specifying references. Closes: #151960.
140 * Added -d command-line option to enable imaplib debugging.
141
142 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 20:39:29 -0500
143
144 offlineimap (2.0.2) unstable; urgency=low
145
146 * Added support for remotepassfile. Closes: #151943.
147 * Added support for preauth tunnels.
148
149 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 14:46:23 -0500
150
151 offlineimap (2.0.1) unstable; urgency=low
152
153 * Fixed a bug with not properly propogating foldersep changes.
154 Now, local folders and status folders properly use the foldersep
155 mechanism. This corrects a problem with Exchange servers.
156 * Wrote a major new thread montiring subsystem, defined a new
157 ExitNotifyThread. Handling of Ctrl-C now occurs within 1 second
158 rather than after the whole program terminates. Exceptions that
159 occur in a thread are now caught by the main thread and marshalled
160 over into the UI side of things for dispatch. The entire program will
161 now abort when one thread dies with an exception.
162
163 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 09:07:06 -0500
164
165 offlineimap (2.0.0) unstable; urgency=low
166
167 * This code is now multithreaded. New config file options control the
168 behavior. This can make synchronizing several times faster.
169 * Fixed the STATUS call to be compatible with Exchange.
170 * Added the ability to exclude folders.
171 * If upgrading from 1.0.x, you will need to add maxsyncaccounts to the
172 general section and maxconnections to each account sections.
173 There is also a new folderfilter option.
174 You can find examples of all of these in the new offlineimap.conf
175 example file packaged with the distribution.
176 * The Debian package now properly installs the example offlineimap.conf
177 file.
178 * There is a new mailing list available. To join, send SUBSCRIBE
179 to offlineimap-request@complete.org. The posting address is
180 offlineimap@complete.org.
181
182 -- John Goerzen <jgoerzen@complete.org> Wed, 3 Jul 2002 19:21:32 -0500
183
184 offlineimap (1.0.4) unstable; urgency=low
185
186 * Deletion of more than one message has been optimized. This could make
187 deleting large numbers of messages far faster -- several orders of
188 magnitude.
189 * Moved more sleep code into ui layer. Fancier sleep actions are now
190 possible. Better handling of Ctrl-C in TTY handler.
191
192 -- John Goerzen <jgoerzen@complete.org> Tue, 2 Jul 2002 19:16:04 -0500
193
194 offlineimap (1.0.3) unstable; urgency=low
195
196 * Fixed a bug when a message was deleted on the IMAP side and modified
197 on the local side.
198
199 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 19:08:21 -0500
200
201 offlineimap (1.0.2) unstable; urgency=low
202
203 * Made sure that LocalStatus does writing atomically. If the program
204 is interrupted during save(), there will always be a complete copy of
205 either the old or the new data.
206
207 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 06:57:28 -0500
208
209 offlineimap (1.0.1) unstable; urgency=low
210
211 * Fixed a bug with writing messages to some IMAP servers. Turns
212 out we need to issue CHECK between APPEND and SEARCH for some.
213 Thanks to Donovan Lange for reporting this bug and helping track it
214 down.
215
216 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 22:03:12 -0500
217
218 offlineimap (1.0.0) unstable; urgency=low
219
220 * Initial Release. Closes: #150571.
221
222 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 18:54:56 -0500
223
224 Local variables:
225 mode: debian-changelog
226 End: