]> code.delx.au - offlineimap/blob - offlineimap/head/debian/changelog
/offlineimap/head: changeset 136
[offlineimap] / offlineimap / head / debian / changelog
1 offlineimap (3.0.2) unstable; urgency=low
2
3 * Fixed mailbox name recorder to use localfolder.getvisiblename() rather
4 than remotefolder.getvisiblename()
5 * Fixed remotepassfile option. Closes: #153119. Used 1-line patch from
6 Tommi Virtanen.
7 * Now handles cases of not being able to get UID for an uploaded message
8 more gracefully. This could occur if the server doesn't support
9 SEARCH, can't find the message ID, or finds multiple message IDs.
10 Closes: #153241.
11 * Now source is in Subversion. Make version.py log the Subversion
12 revision number.
13
14 -- John Goerzen <jgoerzen@complete.org> Wed, 15 Jul 2002 06:43:36 -0500
15
16 offlineimap (3.0.1) unstable; urgency=low
17
18 * Detabified the source.
19 * Added UI list to the manpage.
20 * Added -o (run only once) option with patch sent in by Martijn Pieters.
21 * Optimized folder/IMAP.py addmessagesflags() with new listjoin() in
22 imaputil. Now, send the server 1:5,7 instead of 1,2,3,4,5,7.
23 * Made folder/Maildir.py/deletemessage() more tolerant if a message
24 asked to be deleted already has been.
25 * In Base.py/copymessageto(), no longer bother calling getmessage()
26 unless a folder's storemessages() returns true. This will also help
27 with syncing to LocalStatus if the user deleted messages in the
28 Maildir since the cachemessagelist() was called.
29
30 -- John Goerzen <jgoerzen@complete.org> Fri, 12 Jul 2002 07:28:24 -0500
31
32 offlineimap (3.0.0) unstable; urgency=low
33
34 * Introduced a new graphical user interface written with Tkinter.
35 It features a nice view of multi-threaded displays.
36 * The TTY user interface now also displays thread names.
37 * Program-wide, new threads are given descriptive names to aid in
38 debugging and status messages.
39 * Added new module offlineimap/ui/detect.py that is used to detect
40 which user interface to select for a given session. Its operation
41 is governed by the ui config option and the -u command-line option.
42 * Made IMAP folder addmessagesflags() resiliant to a server refusing
43 to return a full set of new message flags. Closes: #152587.
44 * Completely rewrote documentation. OfflineIMAP now has an
45 exhaustive manpage, which is really a manual. It is also shipped
46 in plain text, HTML, PDF, and PostScript formats.
47 * New command-line options:
48 -1 to force no multi-threaded operation
49 -u to force a particular UI
50 -a to specify which accounts to sync
51 -h to print help
52 -c to specify an alternate config file
53 * Added a workaround for UW IMAP problem wherein the server loses
54 uidvalidity whenever a folder is emptied. Now, the program
55 will not consider it a problem if uidvalidity is lost when a folder
56 and the local status cache are both completely empty, since we do
57 not really need to preserve uidvalidity in that case anyway.
58 Closes: #152079.
59
60 -- John Goerzen <jgoerzen@complete.org> Thu, 11 Jul 2002 22:35:42 -0500
61
62 offlineimap (2.0.8) unstable; urgency=low
63
64 * Modified the IMAP folder to use SELECT rather than STATUS more often.
65 Makes the code more robust; handles better with read-only folders;
66 and runs faster, especially for non-threaded useres, where it
67 may eliminate up to 2-3 commands per folder.
68 * Made sure IMAP folder savemessage() does a select. This was a possible
69 bug.
70 * Modified Maildir folder to unlink messages with T flag in
71 cachemessagelist()
72 * My own box now syncs in 3 seconds.
73 * Optimized acquireconnection() to try to give a thread back the
74 connection that it last used, if possible.
75
76 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 23:29:30 -0500
77
78 offlineimap (2.0.7) unstable; urgency=low
79
80 * Fixed imaplib.py to work better with read-only folders.
81
82 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:24:21 -0500
83
84 offlineimap (2.0.6) unstable; urgency=low
85
86 * Added support for holdconnectionopen and keepalive. This feature
87 allows for an IMAP server connection(s) to be held open until
88 the next sync process, permitting faster restart times.
89 * Another try at read-only folder support. This is nasty because I
90 have no way to test it and imaplib's read-only support is weird.
91 * Closing out old bug; fixed in 1.0.2. Closes: #150803.
92 * Optimized algorithm so that a SELECT is never issued for folders
93 that contain no messages.
94
95 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:05:24 -0500
96
97 offlineimap (2.0.5) unstable; urgency=low
98
99 * Fixed a folderfilter example. Partially fixes #152079.
100 * Added folderincludes capability. Partially fixes #152079.
101 * More fixes for read-only folders.
102
103 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:21:52 -0500
104
105 offlineimap (2.0.4) unstable; urgency=low
106
107 * Made OfflineIMAP at least rudimentarily compatible with read-only
108 folders. It will still fail if they get modified locally, though.
109 * Flags are handled case-insensitively. Closes: #151993.
110
111 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:10:29 -0500
112
113 offlineimap (2.0.3) unstable; urgency=low
114
115 * Added support for specifying references. Closes: #151960.
116 * Added -d command-line option to enable imaplib debugging.
117
118 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 20:39:29 -0500
119
120 offlineimap (2.0.2) unstable; urgency=low
121
122 * Added support for remotepassfile. Closes: #151943.
123 * Added support for preauth tunnels.
124
125 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 14:46:23 -0500
126
127 offlineimap (2.0.1) unstable; urgency=low
128
129 * Fixed a bug with not properly propogating foldersep changes.
130 Now, local folders and status folders properly use the foldersep
131 mechanism. This corrects a problem with Exchange servers.
132 * Wrote a major new thread montiring subsystem, defined a new
133 ExitNotifyThread. Handling of Ctrl-C now occurs within 1 second
134 rather than after the whole program terminates. Exceptions that
135 occur in a thread are now caught by the main thread and marshalled
136 over into the UI side of things for dispatch. The entire program will
137 now abort when one thread dies with an exception.
138
139 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 09:07:06 -0500
140
141 offlineimap (2.0.0) unstable; urgency=low
142
143 * This code is now multithreaded. New config file options control the
144 behavior. This can make synchronizing several times faster.
145 * Fixed the STATUS call to be compatible with Exchange.
146 * Added the ability to exclude folders.
147 * If upgrading from 1.0.x, you will need to add maxsyncaccounts to the
148 general section and maxconnections to each account sections.
149 There is also a new folderfilter option.
150 You can find examples of all of these in the new offlineimap.conf
151 example file packaged with the distribution.
152 * The Debian package now properly installs the example offlineimap.conf
153 file.
154 * There is a new mailing list available. To join, send SUBSCRIBE
155 to offlineimap-request@complete.org. The posting address is
156 offlineimap@complete.org.
157
158 -- John Goerzen <jgoerzen@complete.org> Wed, 3 Jul 2002 19:21:32 -0500
159
160 offlineimap (1.0.4) unstable; urgency=low
161
162 * Deletion of more than one message has been optimized. This could make
163 deleting large numbers of messages far faster -- several orders of
164 magnitude.
165 * Moved more sleep code into ui layer. Fancier sleep actions are now
166 possible. Better handling of Ctrl-C in TTY handler.
167
168 -- John Goerzen <jgoerzen@complete.org> Tue, 2 Jul 2002 19:16:04 -0500
169
170 offlineimap (1.0.3) unstable; urgency=low
171
172 * Fixed a bug when a message was deleted on the IMAP side and modified
173 on the local side.
174
175 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 19:08:21 -0500
176
177 offlineimap (1.0.2) unstable; urgency=low
178
179 * Made sure that LocalStatus does writing atomically. If the program
180 is interrupted during save(), there will always be a complete copy of
181 either the old or the new data.
182
183 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 06:57:28 -0500
184
185 offlineimap (1.0.1) unstable; urgency=low
186
187 * Fixed a bug with writing messages to some IMAP servers. Turns
188 out we need to issue CHECK between APPEND and SEARCH for some.
189 Thanks to Donovan Lange for reporting this bug and helping track it
190 down.
191
192 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 22:03:12 -0500
193
194 offlineimap (1.0.0) unstable; urgency=low
195
196 * Initial Release. Closes: #150571.
197
198 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 18:54:56 -0500
199
200 Local variables:
201 mode: debian-changelog
202 End: