]> code.delx.au - offlineimap/blob - head/debian/rules
/head: changeset 45
[offlineimap] / head / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 # This is the debhelper compatibility version to use.
9 export DH_COMPAT=3
10
11
12
13 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
14 CFLAGS += -g
15 endif
16 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
17 INSTALL_PROGRAM += -s
18 endif
19
20 configure: configure-stamp
21 configure-stamp:
22 dh_testdir
23 # Add here commands to configure the package.
24
25 touch configure-stamp
26
27
28 build: build-stamp
29
30 build-stamp: configure-stamp
31 dh_testdir
32
33 # Add here commands to compile the package.
34 $(MAKE)
35 #/usr/bin/docbook-to-man debian/offlineimap.sgml > offlineimap.1
36
37 touch build-stamp
38
39 clean:
40 dh_testdir
41 dh_testroot
42 rm -f build-stamp configure-stamp
43
44 # Add here commands to clean up after the build process.
45 -$(MAKE) clean
46
47 dh_clean
48
49 install: build
50 dh_testdir
51 dh_testroot
52 dh_clean -k
53 dh_installdirs
54
55 # Add here commands to install the package into debian/offlineimap.
56 $(MAKE) install DESTDIR=$(CURDIR)/debian/offlineimap
57
58
59 # Build architecture-independent files here.
60 binary-indep: build install
61 # We have nothing to do by default.
62
63 # Build architecture-dependent files here.
64 binary-arch: build install
65 dh_testdir
66 dh_testroot
67 # dh_installdebconf
68 dh_installdocs
69 dh_installexamples
70 dh_installmenu
71 # dh_installlogrotate
72 # dh_installemacsen
73 # dh_installpam
74 # dh_installmime
75 # dh_installinit
76 dh_installcron
77 dh_installman
78 dh_installinfo
79 # dh_undocumented
80 dh_installchangelogs ChangeLog
81 dh_link
82 dh_strip
83 dh_compress
84 dh_fixperms
85 # dh_makeshlibs
86 dh_installdeb
87 # dh_perl
88 dh_shlibdeps
89 dh_gencontrol
90 dh_md5sums
91 dh_builddeb
92
93 binary: binary-indep binary-arch
94 .PHONY: build clean binary-indep binary-arch binary install configure