]> code.delx.au - offlineimap/blob - offlineimap/head/debian/changelog
/offlineimap/head: changeset 170
[offlineimap] / offlineimap / head / debian / changelog
1 offlineimap (3.1.1) unstable; urgency=low
2
3 * Modified imaputil.py and folder/Maildir.py to run faster. Eliminated
4 many regular expressions; pre-compiled many others.
5 * Fixed threadutil's exitnotifyloop to always handle threads in the order
6 they exited, rather than sometimes in the inverse order. This way,
7 make sure to handle thread's exception messages before a thread exited.
8 * Replaced imaplib.py's braindead readline() with a more efficient one.
9 * More optimizations to imaputil and folders for faster operation.
10
11 -- John Goerzen <jgoerzen@complete.org> Tue, 23 Jul 2002 06:53:16 -0500
12
13 offlineimap (3.1.0) unstable; urgency=low
14
15 * When uploading messages from a Maildir, now convert \r\n to \n in case
16 the message is stored weirdly. That way, everything is uniform.
17 Fixes [complete.org #11].
18 * Manual: added UW IMAPD example with references from docwhat@gerf.org.
19 * New UI modules: Noninteractive.Basic and Noninteractive.Quiet.
20 Fixes [complete.org #14].
21 * Added per-thread profiling support to aid in debugging.
22
23 -- John Goerzen <jgoerzen@complete.org> Sun, 21 Jul 2002 16:09:42 -0500
24
25 offlineimap (3.0.3) unstable; urgency=low
26
27 * No longer throws an exception when updating messages with strange
28 Date headers; will just set IMAP Internaldate to the current date.
29 Closes: #153425.
30 * No longer doubles-up reference names for mailboxes. Closes: #153515.
31 * Noted new bug-tracking system in manual and rebuilt manual files.
32 * Now stores incoming messages in 'cur' instead of 'new' if they have
33 the S flag. Closes: #152482.
34
35 -- John Goerzen <jgoerzen@complete.org> Sun, 21 Jul 2002 13:46:13 -0500
36
37 offlineimap (3.0.2) unstable; urgency=low
38
39 * Fixed mailbox name recorder to use localfolder.getvisiblename() rather
40 than remotefolder.getvisiblename()
41 * Fixed remotepassfile option. Closes: #153119. Used 1-line patch from
42 Tommi Virtanen.
43 * Now handles cases of not being able to get UID for an uploaded message
44 more gracefully. This could occur if the server doesn't support
45 SEARCH, can't find the message ID, or finds multiple message IDs.
46 Closes: #153241.
47 * Now source is in Subversion. Make version.py log the Subversion
48 revision number.
49
50 -- John Goerzen <jgoerzen@complete.org> Wed, 15 Jul 2002 06:43:36 -0500
51
52 offlineimap (3.0.1) unstable; urgency=low
53
54 * Detabified the source.
55 * Added UI list to the manpage.
56 * Added -o (run only once) option with patch sent in by Martijn Pieters.
57 * Optimized folder/IMAP.py addmessagesflags() with new listjoin() in
58 imaputil. Now, send the server 1:5,7 instead of 1,2,3,4,5,7.
59 * Made folder/Maildir.py/deletemessage() more tolerant if a message
60 asked to be deleted already has been.
61 * In Base.py/copymessageto(), no longer bother calling getmessage()
62 unless a folder's storemessages() returns true. This will also help
63 with syncing to LocalStatus if the user deleted messages in the
64 Maildir since the cachemessagelist() was called.
65
66 -- John Goerzen <jgoerzen@complete.org> Fri, 12 Jul 2002 07:28:24 -0500
67
68 offlineimap (3.0.0) unstable; urgency=low
69
70 * Introduced a new graphical user interface written with Tkinter.
71 It features a nice view of multi-threaded displays.
72 * The TTY user interface now also displays thread names.
73 * Program-wide, new threads are given descriptive names to aid in
74 debugging and status messages.
75 * Added new module offlineimap/ui/detect.py that is used to detect
76 which user interface to select for a given session. Its operation
77 is governed by the ui config option and the -u command-line option.
78 * Made IMAP folder addmessagesflags() resiliant to a server refusing
79 to return a full set of new message flags. Closes: #152587.
80 * Completely rewrote documentation. OfflineIMAP now has an
81 exhaustive manpage, which is really a manual. It is also shipped
82 in plain text, HTML, PDF, and PostScript formats.
83 * New command-line options:
84 -1 to force no multi-threaded operation
85 -u to force a particular UI
86 -a to specify which accounts to sync
87 -h to print help
88 -c to specify an alternate config file
89 * Added a workaround for UW IMAP problem wherein the server loses
90 uidvalidity whenever a folder is emptied. Now, the program
91 will not consider it a problem if uidvalidity is lost when a folder
92 and the local status cache are both completely empty, since we do
93 not really need to preserve uidvalidity in that case anyway.
94 Closes: #152079.
95
96 -- John Goerzen <jgoerzen@complete.org> Thu, 11 Jul 2002 22:35:42 -0500
97
98 offlineimap (2.0.8) unstable; urgency=low
99
100 * Modified the IMAP folder to use SELECT rather than STATUS more often.
101 Makes the code more robust; handles better with read-only folders;
102 and runs faster, especially for non-threaded useres, where it
103 may eliminate up to 2-3 commands per folder.
104 * Made sure IMAP folder savemessage() does a select. This was a possible
105 bug.
106 * Modified Maildir folder to unlink messages with T flag in
107 cachemessagelist()
108 * My own box now syncs in 3 seconds.
109 * Optimized acquireconnection() to try to give a thread back the
110 connection that it last used, if possible.
111
112 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 23:29:30 -0500
113
114 offlineimap (2.0.7) unstable; urgency=low
115
116 * Fixed imaplib.py to work better with read-only folders.
117
118 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:24:21 -0500
119
120 offlineimap (2.0.6) unstable; urgency=low
121
122 * Added support for holdconnectionopen and keepalive. This feature
123 allows for an IMAP server connection(s) to be held open until
124 the next sync process, permitting faster restart times.
125 * Another try at read-only folder support. This is nasty because I
126 have no way to test it and imaplib's read-only support is weird.
127 * Closing out old bug; fixed in 1.0.2. Closes: #150803.
128 * Optimized algorithm so that a SELECT is never issued for folders
129 that contain no messages.
130
131 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:05:24 -0500
132
133 offlineimap (2.0.5) unstable; urgency=low
134
135 * Fixed a folderfilter example. Partially fixes #152079.
136 * Added folderincludes capability. Partially fixes #152079.
137 * More fixes for read-only folders.
138
139 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:21:52 -0500
140
141 offlineimap (2.0.4) unstable; urgency=low
142
143 * Made OfflineIMAP at least rudimentarily compatible with read-only
144 folders. It will still fail if they get modified locally, though.
145 * Flags are handled case-insensitively. Closes: #151993.
146
147 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:10:29 -0500
148
149 offlineimap (2.0.3) unstable; urgency=low
150
151 * Added support for specifying references. Closes: #151960.
152 * Added -d command-line option to enable imaplib debugging.
153
154 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 20:39:29 -0500
155
156 offlineimap (2.0.2) unstable; urgency=low
157
158 * Added support for remotepassfile. Closes: #151943.
159 * Added support for preauth tunnels.
160
161 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 14:46:23 -0500
162
163 offlineimap (2.0.1) unstable; urgency=low
164
165 * Fixed a bug with not properly propogating foldersep changes.
166 Now, local folders and status folders properly use the foldersep
167 mechanism. This corrects a problem with Exchange servers.
168 * Wrote a major new thread montiring subsystem, defined a new
169 ExitNotifyThread. Handling of Ctrl-C now occurs within 1 second
170 rather than after the whole program terminates. Exceptions that
171 occur in a thread are now caught by the main thread and marshalled
172 over into the UI side of things for dispatch. The entire program will
173 now abort when one thread dies with an exception.
174
175 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 09:07:06 -0500
176
177 offlineimap (2.0.0) unstable; urgency=low
178
179 * This code is now multithreaded. New config file options control the
180 behavior. This can make synchronizing several times faster.
181 * Fixed the STATUS call to be compatible with Exchange.
182 * Added the ability to exclude folders.
183 * If upgrading from 1.0.x, you will need to add maxsyncaccounts to the
184 general section and maxconnections to each account sections.
185 There is also a new folderfilter option.
186 You can find examples of all of these in the new offlineimap.conf
187 example file packaged with the distribution.
188 * The Debian package now properly installs the example offlineimap.conf
189 file.
190 * There is a new mailing list available. To join, send SUBSCRIBE
191 to offlineimap-request@complete.org. The posting address is
192 offlineimap@complete.org.
193
194 -- John Goerzen <jgoerzen@complete.org> Wed, 3 Jul 2002 19:21:32 -0500
195
196 offlineimap (1.0.4) unstable; urgency=low
197
198 * Deletion of more than one message has been optimized. This could make
199 deleting large numbers of messages far faster -- several orders of
200 magnitude.
201 * Moved more sleep code into ui layer. Fancier sleep actions are now
202 possible. Better handling of Ctrl-C in TTY handler.
203
204 -- John Goerzen <jgoerzen@complete.org> Tue, 2 Jul 2002 19:16:04 -0500
205
206 offlineimap (1.0.3) unstable; urgency=low
207
208 * Fixed a bug when a message was deleted on the IMAP side and modified
209 on the local side.
210
211 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 19:08:21 -0500
212
213 offlineimap (1.0.2) unstable; urgency=low
214
215 * Made sure that LocalStatus does writing atomically. If the program
216 is interrupted during save(), there will always be a complete copy of
217 either the old or the new data.
218
219 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 06:57:28 -0500
220
221 offlineimap (1.0.1) unstable; urgency=low
222
223 * Fixed a bug with writing messages to some IMAP servers. Turns
224 out we need to issue CHECK between APPEND and SEARCH for some.
225 Thanks to Donovan Lange for reporting this bug and helping track it
226 down.
227
228 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 22:03:12 -0500
229
230 offlineimap (1.0.0) unstable; urgency=low
231
232 * Initial Release. Closes: #150571.
233
234 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 18:54:56 -0500
235
236 Local variables:
237 mode: debian-changelog
238 End: