]> code.delx.au - offlineimap/blob - offlineimap/head/debian/changelog
/offlineimap/head: changeset 135
[offlineimap] / offlineimap / head / debian / changelog
1 offlineimap (3.0.2) unstable; urgency=low
2
3 * Fixed mailbox name recorder to use localfolder.getvisiblename() rather
4 than remotefolder.getvisiblename()
5 * Fixed remotepassfile option. Closes: #153119. Used 1-line patch from
6 Tommi Virtanen.
7 * Now handles cases of not being able to get UID for an uploaded message
8 more gracefully. This could occur if the server doesn't support
9 SEARCH, can't find the message ID, or finds multiple message IDs.
10 Closes: #153241.
11
12 -- John Goerzen <jgoerzen@complete.org> Wed, 15 Jul 2002 06:43:36 -0500
13
14 offlineimap (3.0.1) unstable; urgency=low
15
16 * Detabified the source.
17 * Added UI list to the manpage.
18 * Added -o (run only once) option with patch sent in by Martijn Pieters.
19 * Optimized folder/IMAP.py addmessagesflags() with new listjoin() in
20 imaputil. Now, send the server 1:5,7 instead of 1,2,3,4,5,7.
21 * Made folder/Maildir.py/deletemessage() more tolerant if a message
22 asked to be deleted already has been.
23 * In Base.py/copymessageto(), no longer bother calling getmessage()
24 unless a folder's storemessages() returns true. This will also help
25 with syncing to LocalStatus if the user deleted messages in the
26 Maildir since the cachemessagelist() was called.
27
28 -- John Goerzen <jgoerzen@complete.org> Fri, 12 Jul 2002 07:28:24 -0500
29
30 offlineimap (3.0.0) unstable; urgency=low
31
32 * Introduced a new graphical user interface written with Tkinter.
33 It features a nice view of multi-threaded displays.
34 * The TTY user interface now also displays thread names.
35 * Program-wide, new threads are given descriptive names to aid in
36 debugging and status messages.
37 * Added new module offlineimap/ui/detect.py that is used to detect
38 which user interface to select for a given session. Its operation
39 is governed by the ui config option and the -u command-line option.
40 * Made IMAP folder addmessagesflags() resiliant to a server refusing
41 to return a full set of new message flags. Closes: #152587.
42 * Completely rewrote documentation. OfflineIMAP now has an
43 exhaustive manpage, which is really a manual. It is also shipped
44 in plain text, HTML, PDF, and PostScript formats.
45 * New command-line options:
46 -1 to force no multi-threaded operation
47 -u to force a particular UI
48 -a to specify which accounts to sync
49 -h to print help
50 -c to specify an alternate config file
51 * Added a workaround for UW IMAP problem wherein the server loses
52 uidvalidity whenever a folder is emptied. Now, the program
53 will not consider it a problem if uidvalidity is lost when a folder
54 and the local status cache are both completely empty, since we do
55 not really need to preserve uidvalidity in that case anyway.
56 Closes: #152079.
57
58 -- John Goerzen <jgoerzen@complete.org> Thu, 11 Jul 2002 22:35:42 -0500
59
60 offlineimap (2.0.8) unstable; urgency=low
61
62 * Modified the IMAP folder to use SELECT rather than STATUS more often.
63 Makes the code more robust; handles better with read-only folders;
64 and runs faster, especially for non-threaded useres, where it
65 may eliminate up to 2-3 commands per folder.
66 * Made sure IMAP folder savemessage() does a select. This was a possible
67 bug.
68 * Modified Maildir folder to unlink messages with T flag in
69 cachemessagelist()
70 * My own box now syncs in 3 seconds.
71 * Optimized acquireconnection() to try to give a thread back the
72 connection that it last used, if possible.
73
74 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 23:29:30 -0500
75
76 offlineimap (2.0.7) unstable; urgency=low
77
78 * Fixed imaplib.py to work better with read-only folders.
79
80 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:24:21 -0500
81
82 offlineimap (2.0.6) unstable; urgency=low
83
84 * Added support for holdconnectionopen and keepalive. This feature
85 allows for an IMAP server connection(s) to be held open until
86 the next sync process, permitting faster restart times.
87 * Another try at read-only folder support. This is nasty because I
88 have no way to test it and imaplib's read-only support is weird.
89 * Closing out old bug; fixed in 1.0.2. Closes: #150803.
90 * Optimized algorithm so that a SELECT is never issued for folders
91 that contain no messages.
92
93 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:05:24 -0500
94
95 offlineimap (2.0.5) unstable; urgency=low
96
97 * Fixed a folderfilter example. Partially fixes #152079.
98 * Added folderincludes capability. Partially fixes #152079.
99 * More fixes for read-only folders.
100
101 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:21:52 -0500
102
103 offlineimap (2.0.4) unstable; urgency=low
104
105 * Made OfflineIMAP at least rudimentarily compatible with read-only
106 folders. It will still fail if they get modified locally, though.
107 * Flags are handled case-insensitively. Closes: #151993.
108
109 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:10:29 -0500
110
111 offlineimap (2.0.3) unstable; urgency=low
112
113 * Added support for specifying references. Closes: #151960.
114 * Added -d command-line option to enable imaplib debugging.
115
116 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 20:39:29 -0500
117
118 offlineimap (2.0.2) unstable; urgency=low
119
120 * Added support for remotepassfile. Closes: #151943.
121 * Added support for preauth tunnels.
122
123 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 14:46:23 -0500
124
125 offlineimap (2.0.1) unstable; urgency=low
126
127 * Fixed a bug with not properly propogating foldersep changes.
128 Now, local folders and status folders properly use the foldersep
129 mechanism. This corrects a problem with Exchange servers.
130 * Wrote a major new thread montiring subsystem, defined a new
131 ExitNotifyThread. Handling of Ctrl-C now occurs within 1 second
132 rather than after the whole program terminates. Exceptions that
133 occur in a thread are now caught by the main thread and marshalled
134 over into the UI side of things for dispatch. The entire program will
135 now abort when one thread dies with an exception.
136
137 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 09:07:06 -0500
138
139 offlineimap (2.0.0) unstable; urgency=low
140
141 * This code is now multithreaded. New config file options control the
142 behavior. This can make synchronizing several times faster.
143 * Fixed the STATUS call to be compatible with Exchange.
144 * Added the ability to exclude folders.
145 * If upgrading from 1.0.x, you will need to add maxsyncaccounts to the
146 general section and maxconnections to each account sections.
147 There is also a new folderfilter option.
148 You can find examples of all of these in the new offlineimap.conf
149 example file packaged with the distribution.
150 * The Debian package now properly installs the example offlineimap.conf
151 file.
152 * There is a new mailing list available. To join, send SUBSCRIBE
153 to offlineimap-request@complete.org. The posting address is
154 offlineimap@complete.org.
155
156 -- John Goerzen <jgoerzen@complete.org> Wed, 3 Jul 2002 19:21:32 -0500
157
158 offlineimap (1.0.4) unstable; urgency=low
159
160 * Deletion of more than one message has been optimized. This could make
161 deleting large numbers of messages far faster -- several orders of
162 magnitude.
163 * Moved more sleep code into ui layer. Fancier sleep actions are now
164 possible. Better handling of Ctrl-C in TTY handler.
165
166 -- John Goerzen <jgoerzen@complete.org> Tue, 2 Jul 2002 19:16:04 -0500
167
168 offlineimap (1.0.3) unstable; urgency=low
169
170 * Fixed a bug when a message was deleted on the IMAP side and modified
171 on the local side.
172
173 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 19:08:21 -0500
174
175 offlineimap (1.0.2) unstable; urgency=low
176
177 * Made sure that LocalStatus does writing atomically. If the program
178 is interrupted during save(), there will always be a complete copy of
179 either the old or the new data.
180
181 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 06:57:28 -0500
182
183 offlineimap (1.0.1) unstable; urgency=low
184
185 * Fixed a bug with writing messages to some IMAP servers. Turns
186 out we need to issue CHECK between APPEND and SEARCH for some.
187 Thanks to Donovan Lange for reporting this bug and helping track it
188 down.
189
190 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 22:03:12 -0500
191
192 offlineimap (1.0.0) unstable; urgency=low
193
194 * Initial Release. Closes: #150571.
195
196 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 18:54:56 -0500
197
198 Local variables:
199 mode: debian-changelog
200 End: