]> code.delx.au - offlineimap/blob - head/debian/changelog
/head: changeset 120
[offlineimap] / head / debian / changelog
1 offlineimap (3.0.1) unstable; urgency=low
2
3 * Detabified the source.
4 * Added UI list to the manpage.
5
6 -- John Goerzen <jgoerzen@complete.org> Fri, 12 Jul 2002 07:28:24 -0500
7
8 offlineimap (3.0.0) unstable; urgency=low
9
10 * Introduced a new graphical user interface written with Tkinter.
11 It features a nice view of multi-threaded displays.
12 * The TTY user interface now also displays thread names.
13 * Program-wide, new threads are given descriptive names to aid in
14 debugging and status messages.
15 * Added new module offlineimap/ui/detect.py that is used to detect
16 which user interface to select for a given session. Its operation
17 is governed by the ui config option and the -u command-line option.
18 * Made IMAP folder addmessagesflags() resiliant to a server refusing
19 to return a full set of new message flags. Closes: #152587.
20 * Completely rewrote documentation. OfflineIMAP now has an
21 exhaustive manpage, which is really a manual. It is also shipped
22 in plain text, HTML, PDF, and PostScript formats.
23 * New command-line options:
24 -1 to force no multi-threaded operation
25 -u to force a particular UI
26 -a to specify which accounts to sync
27 -h to print help
28 -c to specify an alternate config file
29 * Added a workaround for UW IMAP problem wherein the server loses
30 uidvalidity whenever a folder is emptied. Now, the program
31 will not consider it a problem if uidvalidity is lost when a folder
32 and the local status cache are both completely empty, since we do
33 not really need to preserve uidvalidity in that case anyway.
34 Closes: #152079.
35
36 -- John Goerzen <jgoerzen@complete.org> Thu, 11 Jul 2002 22:35:42 -0500
37
38 offlineimap (2.0.8) unstable; urgency=low
39
40 * Modified the IMAP folder to use SELECT rather than STATUS more often.
41 Makes the code more robust; handles better with read-only folders;
42 and runs faster, especially for non-threaded useres, where it
43 may eliminate up to 2-3 commands per folder.
44 * Made sure IMAP folder savemessage() does a select. This was a possible
45 bug.
46 * Modified Maildir folder to unlink messages with T flag in
47 cachemessagelist()
48 * My own box now syncs in 3 seconds.
49 * Optimized acquireconnection() to try to give a thread back the
50 connection that it last used, if possible.
51
52 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 23:29:30 -0500
53
54 offlineimap (2.0.7) unstable; urgency=low
55
56 * Fixed imaplib.py to work better with read-only folders.
57
58 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:24:21 -0500
59
60 offlineimap (2.0.6) unstable; urgency=low
61
62 * Added support for holdconnectionopen and keepalive. This feature
63 allows for an IMAP server connection(s) to be held open until
64 the next sync process, permitting faster restart times.
65 * Another try at read-only folder support. This is nasty because I
66 have no way to test it and imaplib's read-only support is weird.
67 * Closing out old bug; fixed in 1.0.2. Closes: #150803.
68 * Optimized algorithm so that a SELECT is never issued for folders
69 that contain no messages.
70
71 -- John Goerzen <jgoerzen@complete.org> Tue, 9 Jul 2002 20:05:24 -0500
72
73 offlineimap (2.0.5) unstable; urgency=low
74
75 * Fixed a folderfilter example. Partially fixes #152079.
76 * Added folderincludes capability. Partially fixes #152079.
77 * More fixes for read-only folders.
78
79 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:21:52 -0500
80
81 offlineimap (2.0.4) unstable; urgency=low
82
83 * Made OfflineIMAP at least rudimentarily compatible with read-only
84 folders. It will still fail if they get modified locally, though.
85 * Flags are handled case-insensitively. Closes: #151993.
86
87 -- John Goerzen <jgoerzen@complete.org> Fri, 5 Jul 2002 09:10:29 -0500
88
89 offlineimap (2.0.3) unstable; urgency=low
90
91 * Added support for specifying references. Closes: #151960.
92 * Added -d command-line option to enable imaplib debugging.
93
94 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 20:39:29 -0500
95
96 offlineimap (2.0.2) unstable; urgency=low
97
98 * Added support for remotepassfile. Closes: #151943.
99 * Added support for preauth tunnels.
100
101 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 14:46:23 -0500
102
103 offlineimap (2.0.1) unstable; urgency=low
104
105 * Fixed a bug with not properly propogating foldersep changes.
106 Now, local folders and status folders properly use the foldersep
107 mechanism. This corrects a problem with Exchange servers.
108 * Wrote a major new thread montiring subsystem, defined a new
109 ExitNotifyThread. Handling of Ctrl-C now occurs within 1 second
110 rather than after the whole program terminates. Exceptions that
111 occur in a thread are now caught by the main thread and marshalled
112 over into the UI side of things for dispatch. The entire program will
113 now abort when one thread dies with an exception.
114
115 -- John Goerzen <jgoerzen@complete.org> Thu, 4 Jul 2002 09:07:06 -0500
116
117 offlineimap (2.0.0) unstable; urgency=low
118
119 * This code is now multithreaded. New config file options control the
120 behavior. This can make synchronizing several times faster.
121 * Fixed the STATUS call to be compatible with Exchange.
122 * Added the ability to exclude folders.
123 * If upgrading from 1.0.x, you will need to add maxsyncaccounts to the
124 general section and maxconnections to each account sections.
125 There is also a new folderfilter option.
126 You can find examples of all of these in the new offlineimap.conf
127 example file packaged with the distribution.
128 * The Debian package now properly installs the example offlineimap.conf
129 file.
130 * There is a new mailing list available. To join, send SUBSCRIBE
131 to offlineimap-request@complete.org. The posting address is
132 offlineimap@complete.org.
133
134 -- John Goerzen <jgoerzen@complete.org> Wed, 3 Jul 2002 19:21:32 -0500
135
136 offlineimap (1.0.4) unstable; urgency=low
137
138 * Deletion of more than one message has been optimized. This could make
139 deleting large numbers of messages far faster -- several orders of
140 magnitude.
141 * Moved more sleep code into ui layer. Fancier sleep actions are now
142 possible. Better handling of Ctrl-C in TTY handler.
143
144 -- John Goerzen <jgoerzen@complete.org> Tue, 2 Jul 2002 19:16:04 -0500
145
146 offlineimap (1.0.3) unstable; urgency=low
147
148 * Fixed a bug when a message was deleted on the IMAP side and modified
149 on the local side.
150
151 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 19:08:21 -0500
152
153 offlineimap (1.0.2) unstable; urgency=low
154
155 * Made sure that LocalStatus does writing atomically. If the program
156 is interrupted during save(), there will always be a complete copy of
157 either the old or the new data.
158
159 -- John Goerzen <jgoerzen@complete.org> Mon, 24 Jun 2002 06:57:28 -0500
160
161 offlineimap (1.0.1) unstable; urgency=low
162
163 * Fixed a bug with writing messages to some IMAP servers. Turns
164 out we need to issue CHECK between APPEND and SEARCH for some.
165 Thanks to Donovan Lange for reporting this bug and helping track it
166 down.
167
168 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 22:03:12 -0500
169
170 offlineimap (1.0.0) unstable; urgency=low
171
172 * Initial Release. Closes: #150571.
173
174 -- John Goerzen <jgoerzen@complete.org> Fri, 21 Jun 2002 18:54:56 -0500
175
176 Local variables:
177 mode: debian-changelog
178 End: