]> code.delx.au - offlineimap/blob - head/debian/rules
/head: changeset 58
[offlineimap] / head / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4 # Modified by John Goerzen
5
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
8
9 # This is the debhelper compatibility version to use.
10 export DH_COMPAT=3
11
12 PYTHON=python2.2
13 PACKAGE=offlineimap
14
15
16 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
17 CFLAGS += -g
18 endif
19 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
20 INSTALL_PROGRAM += -s
21 endif
22
23 configure: configure-stamp
24 configure-stamp:
25 dh_testdir
26 # Add here commands to configure the package.
27 #$(PYTHON) setup.py configure
28
29 touch configure-stamp
30
31
32 build: build-stamp
33
34 build-stamp: configure-stamp
35 dh_testdir
36
37 # Add here commands to compile the package.
38 $(PYTHON) setup.py build
39 #/usr/bin/docbook-to-man debian/pygopherd.sgml > pygopherd.1
40
41 touch build-stamp
42
43 clean:
44 dh_testdir
45 dh_testroot
46 rm -f build-stamp configure-stamp
47
48 # Add here commands to clean up after the build process.
49 -$(MAKE) clean
50
51 dh_clean
52
53 install: build
54 dh_testdir
55 dh_testroot
56 dh_clean -k
57 dh_installdirs
58
59 # Add here commands to install the package into debian/pygopherd.
60 #$(MAKE) install DESTDIR=$(CURDIR)/debian/pygopherd
61 $(PYTHON) setup.py install --root=`pwd`/debian/$(PACKAGE) --no-compile
62
63
64 # Build architecture-dependent files here.
65 binary-arch: build install
66 # We have nothing to do by default.
67
68 # Build architecture-independent files here.
69 binary-indep: build install
70 dh_testdir
71 dh_testroot
72 # dh_installdebconf
73 dh_installdocs
74 mv debian/$(PACKAGE)/usr/bin/$(PACKAGE).py \
75 debian/$(PACKAGE)/usr/bin/$(PACKAGE)
76 dh_installexamples
77 dh_installmenu
78 # dh_installlogrotate
79 # dh_installemacsen
80 # dh_installpam
81 # dh_installmime
82 dh_installinit
83 dh_installcron
84 dh_installman
85 dh_installinfo
86 # dh_undocumented
87 dh_installchangelogs
88 dh_link
89 dh_strip
90 dh_compress
91 dh_fixperms
92 # dh_makeshlibs
93 dh_installdeb
94 # dh_perl
95 dh_shlibdeps
96 dh_gencontrol
97 dh_md5sums
98 dh_builddeb
99
100 binary: binary-indep binary-arch
101 .PHONY: build clean binary-indep binary-arch binary install configure