]> code.delx.au - refind/blob - refind.spec
3c30d476c7d75068b92aea91b7661894349548c7
[refind] / refind.spec
1 Summary: EFI boot manager software
2 Name: refind
3 Version: 0.6.5.4
4 Release: 1%{?dist}
5 Summary: EFI boot manager software
6 License: GPLv3
7 URL: http://www.rodsbooks.com/refind/
8 Group: System Environment/Base
9 Source: refind-src-%version.zip
10 Requires: efibootmgr
11 BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
12
13 %define efiarch unknown
14 %ifarch i386
15 %define efiarch ia32
16 %endif
17 %ifarch i486
18 %define efiarch ia32
19 %endif
20 %ifarch i586
21 %define efiarch ia32
22 %endif
23 %ifarch i686
24 %define efiarch ia32
25 %endif
26 %ifarch x86_64
27 %define efiarch x64
28 %endif
29
30 # Directory in which refind.key and refind.crt files are found for
31 # signing of binaries. If absent, binaries are copied unsigned.
32 %define keydir /mnt/refind
33
34 %description
35
36 A graphical boot manager for EFI- and UEFI-based computers, such as all
37 Intel-based Macs and recent (most 2011 and later) PCs. rEFInd presents a
38 boot menu showing all the EFI boot loaders on the EFI-accessible
39 partitions, and optionally BIOS-bootable partitions on Macs. EFI-compatbile
40 OSes, including Linux, provide boot loaders that rEFInd can detect and
41 launch. rEFInd can launch Linux EFI boot loaders such as ELILO, GRUB
42 Legacy, GRUB 2, and 3.3.0 and later kernels with EFI stub support. EFI
43 filesystem drivers for ext2/3/4fs, ReiserFS, HFS+, and ISO-9660 enable
44 rEFInd to read boot loaders from these filesystems, too. rEFInd's ability
45 to detect boot loaders at runtime makes it very easy to use, particularly
46 when paired with Linux kernels that provide EFI stub support.
47
48 %prep
49 %setup -q
50
51 %build
52 if [[ -d /usr/local/UDK2010 ]] ; then
53 make
54 make fs
55 else
56 make gnuefi
57 make fs_gnuefi
58 fi
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 mkdir -p $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/
63
64 # Copy the rEFInd binaries (rEFInd proper and drivers) to /usr/share/refind-%{version},
65 # including signing the binaries if sbsign is installed and a %{keydir}/refind.key file
66 # is available
67 declare SBSign=`which sbsign 2> /dev/null`
68 if [[ -f %{keydir}/refind.key && -x $SBSign ]] ; then
69 $SBSign --key %{keydir}/refind.key --cert %{keydir}/refind.crt --output $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/refind_%{efiarch}.efi refind/refind_%{efiarch}.efi
70 mkdir -p $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/drivers_%{efiarch}
71 for File in `ls drivers_%{efiarch}/*_x64.efi` ; do
72 $SBSign --key %{keydir}/refind.key --cert %{keydir}/refind.crt --output $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/$File $File
73 done
74 else
75 install -Dp -m0644 refind/refind*.efi $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/
76 mkdir -p $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/drivers_%{efiarch}
77 cp -a drivers_%{efiarch}/* $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/drivers_%{efiarch}/
78 fi
79
80 # Copy configuration and support files to /usr/share/refind-%{version}
81 install -Dp -m0644 refind.conf-sample $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/
82 cp -a icons $RPM_BUILD_ROOT/usr/share/refind-%{version}/refind/
83 install -Dp -m0755 install.sh $RPM_BUILD_ROOT/usr/share/refind-%{version}/
84
85 # Copy documentation to /usr/share/doc/refind-%{version}
86 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/refind-%{version}
87 cp -a docs/* $RPM_BUILD_ROOT/usr/share/doc/refind-%{version}/
88 install -Dp -m0644 NEWS.txt COPYING.txt LICENSE.txt README.txt CREDITS.txt $RPM_BUILD_ROOT/usr/share/doc/refind-%{version}
89
90 # Copy keys to /etc/refind.d/keys
91 mkdir -p $RPM_BUILD_ROOT/etc/refind.d/keys
92 install -Dp -m0644 keys/* $RPM_BUILD_ROOT/etc/refind.d/keys
93
94 # Copy scripts to /usr/sbin
95 mkdir -p $RPM_BUILD_ROOT/usr/sbin
96 install -Dp -m0755 mkrlconf.sh $RPM_BUILD_ROOT/usr/sbin/
97 install -Dp -m0755 mvrefind.sh $RPM_BUILD_ROOT/usr/sbin/
98
99 %clean
100 #rm -rf $RPM_BUILD_ROOT
101
102 %files
103 %defattr(-,root,root -)
104 %doc /usr/share/doc/refind-%{version}
105 /usr/sbin/mkrlconf.sh
106 /usr/sbin/mvrefind.sh
107 /usr/share/refind-%{version}
108 /etc/refind.d/
109
110 %post
111 PATH=$PATH:/usr/local/bin
112 # Remove any existing NVRAM entry for rEFInd, to avoid creating a duplicate.
113 ExistingEntry=`efibootmgr | grep "rEFInd Boot Manager" | cut -c 5-8`
114 if [[ -n $ExistingEntry ]] ; then
115 efibootmgr --bootnum $ExistingEntry --delete-bootnum
116 fi
117
118 cd /usr/share/refind-%{version}
119
120 declare VarFile=`ls -d /sys/firmware/efi/vars/SecureBoot* 2> /dev/null`
121 declare ShimFile=`find /boot -name shim\.efi 2> /dev/null | grep -v refind | head -n 1`
122 declare SBSign=`which sbsign 2> /dev/null`
123 declare OpenSSL=`which openssl 2> /dev/null`
124
125 # Run the rEFInd installation script. Do so with the --shim option
126 # if Secure Boot mode is suspected and if a shim program can be
127 # found, or without it if not. If a shim installation is attempted
128 # and the sbsign and openssl programs can be found, do the install
129 # using a local signing key. Note that this option is undesirable
130 # for a distribution, since it would then require the user to
131 # enroll an extra MOK. I'm including it here because I'm NOT a
132 # distribution maintainer, and I want to encourage users to use
133 # their own local keys.
134 if [[ -n $VarFile && -n $ShimFile ]] ; then
135 if [[ -n $SBSign && -n $OpenSSL ]] ; then
136 ./install.sh --shim $ShimFile --localkeys --yes
137 else
138 ./install.sh --shim $ShimFile --yes
139 fi
140 else
141 ./install.sh --yes
142 fi
143
144 # CAUTION: Don't create a %preun or a %postun script that deletes the files
145 # installed by install.sh, since that script will run after an update, thus
146 # wiping out the just-updated files.
147
148 %changelog
149 * Wed Jan 16 2013 R Smith <rodsmith@rodsbooks.com> - 0.6.5
150 - Created spec file for 0.6.5 release